macOS Sierra - iMac 21" 4K - Pinwheel on External Disk I/O

Discussion in 'macOS Sierra (10.12)' started by blufrog, Jul 13, 2017.

  1. blufrog macrumors member

    Joined:
    Dec 19, 2014
    #1
    Hi,

    I have a few Macs (two running El Capitan, and one running Sierra).

    The Sierra machine was purchased a couple of months ago, and it has a bizarre problem through a couple of OS updates: when any external disk is connected to the computer via USB (either NTFS or GUID) the system randomly drops the drive, or has a disk initialization error, or just becomes unresponsive on disk I/O with associated pinwheel.

    When this happens, shutdown/restart takes forever, hanging on the spinning icon on the black background, for anywhere up to several minutes.

    This happens any time ANY external disk is connected.

    I use these external disks also on the El Capitan machines without any problems.

    Time Machine also goes nuts on the Sierra computer, working for maybe one or two backups, then it complains it can no longer access the disk.

    I've tried various resets of NVRAM and PRAM, to no avail.

    Just what on earth is going on with Sierra, and does anyone know of any fixes? It only affects the Sierra computer. No problem in over 2 years on the El Capitan systems (both upgraded from Yosemite).

    Having a look around, it seems this problem existed since the Betas, and no resolution was found.

    I even tried downgrading the USB version from 3.0 to 2.0 via a USB 2.0 hub. No change in behavior (but slower drive throughput).

    Arrggghhh!! Thanks. :)
     
  2. blufrog, Jul 19, 2017
    Last edited: Jul 19, 2017

    blufrog thread starter macrumors member

    Joined:
    Dec 19, 2014
    #2
    Making some progress!

    The problem is the drive goes to sleep, but doesn't wake up again!

    Does anyone know how to prevent the drive sleeping in the first place? It's an SSD in a USB 3.0 enclosure.

    Thanks!
     

Share This Page