macOs sierra stuck on black screen on restart or shutdown

Discussion in 'macOS Sierra (10.12)' started by andreeasden, Oct 6, 2016.

Tags:
  1. andreeasden macrumors newbie

    andreeasden

    Joined:
    Oct 6, 2016
    #1
    Hi guys,



    Every time I restart or shutdown my mac after I installed macOS Sierra it will freeze on a black screen and I will have to eventually force shut-down. It works well in safe mode which makes me believe is it is a kernel panick.



    I have a etrecheck report. Any idea what could cause the kernel issue?

    EtreCheck version: 3.0.6 (315)

    Report generated 2016-10-06 17:43:03

    Download EtreCheck from https://etrecheck.com

    Runtime 1:28

    Performance: Excellent



    Click the [Support] links for help with non-Apple products.

    Click the [Details] links for more information about that line.



    Problem: No problem - just checking



    Hardware Information:

    MacBook Pro (Retina, 15-inch, Mid 2015)

    [Technical Specifications] - [User Guide] - [Warranty & Service]

    MacBook Pro - model: MacBookPro11,5

    1 2,8 GHz Intel Core i7 CPU: 4-core

    16 GB RAM Not upgradeable

    BANK 0/DIMM0

    8 GB DDR3 1600 MHz ok

    BANK 1/DIMM0

    8 GB DDR3 1600 MHz ok

    Bluetooth: Good - Handoff/Airdrop2 supported

    Wireless: en0: 802.11 a/b/g/n/ac

    Battery: Health = Normal - Cycle count = 182



    Video Information:

    AMD Radeon R9 M370X - VRAM: 2048 MB

    Color LCD 2880 x 1800

    Intel Iris Pro



    System Software:

    macOS Sierra 10.12 (16A323) - Time since boot: less than an hour



    Disk Information:

    APPLE SSD SM0512G disk0 : (500,28 GB) (Solid State - TRIM: Yes)

    EFI (disk0s1) <not mounted> : 210 MB

    Recovery HD (disk0s3) <not mounted> [Recovery]: 650 MB

    Macintosh HD (disk1) / [Startup]: 499.07 GB (270.89 GB free)

    Encrypted AES-XTS Unlocked

    Core Storage: disk0s2 499.42 GB Online



    USB Information:

    Apple Card Reader

    Apple Inc. Apple Internal Keyboard / Trackpad

    Broadcom Corp. Bluetooth USB Host Controller



    Thunderbolt Information:

    Apple Inc. thunderbolt_bus



    Gatekeeper:

    Anywhere



    Kernel Extensions:

    /Library/Extensions

    [loaded] com.intel.kext.intelhaxm (6.0.1 - SDK 10.9 - 2016-10-06) [Support]



    System Launch Agents:

    [not loaded] 6 Apple tasks

    [loaded] 169 Apple tasks

    [running] 96 Apple tasks



    System Launch Daemons:

    [not loaded] 38 Apple tasks

    [loaded] 160 Apple tasks

    [running] 105 Apple tasks



    Launch Agents:

    [loaded] com.google.keystone.agent.plist (2016-07-12) [Support]

    [loaded] com.oracle.java.Java-Updater.plist (2016-02-04) [Support]



    Launch Daemons:

    [loaded] com.ITK.IPPPrintHelper.plist (2016-02-01) [Support]

    [loaded] com.adobe.SwitchBoard.plist (2016-01-18) [Support]

    [loaded] com.adobe.fpsaud.plist (2016-08-30) [Support]

    [loaded] com.apple.installer.osmessagetracing.plist (2016-09-14)

    [loaded] com.google.keystone.daemon.plist (2016-09-02) [Support]

    [loaded] com.intel.haxm.plist (2015-11-16) [Support]

    [running] com.laravel.valetServer.plist (2016-06-01) [Support]

    [loaded] com.oracle.java.Helper-Tool.plist (2016-02-04) [Support]

    [running] com.oracle.oss.mysql.mysqld.plist (2016-07-01) [Support]

    [not loaded] homebrew.mxcl.dnsmasq.plist (2016-06-01) [Support]

    [not loaded] homebrew.mxcl.php70.plist (2016-09-22) [Support]



    User Launch Agents:

    [loaded] com.adobe.AAM.Updater-1.0.plist (2016-01-18) [Support]

    [loaded] com.bittorrent.uTorrent.plist (2016-02-12)

    [loaded] com.citrixonline.GoToMeeting.G2MUpdate.plist (2016-09-08) [Support]

    [running] com.spotify.webhelper.plist (2016-10-06) [Support]

    [loaded] com.valvesoftware.steamclean.plist (2016-04-13) [Support]

    [running] homebrew.mxcl.php70.plist (2016-05-24) [Support]



    User Login Items:

    Google Drive Application (/Applications/Google Drive.app)

    Google Photos Backup Application (/Applications/Google Photos Backup.app)

    BetterSnapTool Application (/Applications/BetterSnapTool.app)



    Internet Plug-ins:

    AdobeAAMDetect: AdobeAAMDetect 1.0.0.0 - SDK 10.6 (2016-01-19) [Support]

    FlashPlayer-10.6: 23.0.0.162 - SDK 10.9 (2016-09-13) [Support]

    QuickTime Plugin: 7.7.3 (2016-09-14)

    Flash Player: 23.0.0.162 - SDK 10.9 (2016-09-13) [Support]

    o1dbrowserplugin: 5.41.3.0 - SDK 10.8 (2016-04-25) [Support]

    googletalkbrowserplugin: 5.41.3.0 - SDK 10.8 (2015-12-11) [Support]

    JavaAppletPlugin: Java 8 Update 101 build 13 (2016-09-01) Check version



    User internet Plug-ins:

    CitrixOnlineWebDeploymentPlugin: 1.0.105 (2013-04-26) [Support]



    Safari Extensions:

    1Password - AgileBits - https://agilebits.com/onepassword (2016-09-28)

    AdBlock - BetaFish, Inc. - https://getadblock.com (2016-05-23)

    Momentum - Momentum Dashboard Corp. - http://momentumdash.com (2016-02-19)

    Save to Pocket - Read It Later, Inc. - http://getpocket.com/ (2016-01-08)

    Translate - SideTree.com - Apps for Mac and Web - http://SideTree.com/extensions.html#Translate (2016-02-01)

    Open in Internet Explorer - Parallels - http://www.parallels.com (2016-01-09)



    3rd Party Preference Panes:

    Flash Player (2016-08-30) [Support]

    Java (2016-09-01) [Support]

    MySQL (2016-05-25) [Support]



    Time Machine:

    Skip System Files: NO

    Auto backup: YES

    Volumes being backed up:

    Macintosh HD: Disk size: 499.07 GB Disk used: 228.18 GB

    Destinations:

    susn Media Storage [Local]

    Total size: 999.86 GB

    Total number of backups: 24

    Oldest backup: 09/09/2016, 03.39

    Last backup: 06/10/2016, 15.47

    Size of backup disk: Adequate

    Backup size 999.86 GB > (Disk used 228.18 GB X 3)



    Top Processes by CPU:

    30% Google Chrome Helper(18)

    17% Google Chrome

    12% WindowServer

    5% hidd

    4% kernel_task



    Top Processes by Memory:

    1.05 GB kernel_task

    213 MB Google Drive

    164 MB mysqld

    131 MB mds_stores

    115 MB WindowServer



    Virtual Memory Information:

    11.00 GB Free RAM

    5.14 GB Used RAM (2.79 GB Cached)

    0 B Swap Used



    Diagnostics Information:

    Oct 6, 2016, 05:41:04 PM Self test - passed

    Oct 6, 2016, 08:52:25 AM ~/Library/Logs/DiagnosticReports/cloudphotosd_2016-10-06-085225_[redacted].cras h

    com.apple.cloudphotosd - /System/Library/CoreServices/cloudphotosd.app/Contents/MacOS/cloudphotosd

    Oct 6, 2016, 12:42:26 AM ~/Library/Logs/DiagnosticReports/com.apple.WebKit.WebContent_2016-10-06-004226_ [redacted].crash

    /System/Library/Frameworks/WebKit.framework/Versions/A/XPCServices/com.apple.We bKit.WebContent.xpc/Contents/MacOS/com.apple.WebKit.WebContent



    Thanks
     
  2. dianeoforegon macrumors 6502a

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #2
    Try restarting in Safe Boot mode. If you still can't log in, boot into Recovery Drive and select to reinstall macOS Sierra.

    Boot into the Recovery Drive by holding down Command R when restarting.

    Open Disk Utility
    Run First Aid on your internal drive, Macintosh HD
    Quit Disk Utility

    Select Reinstall macOS
    Depending on your internet connection this could take some time to download the installer. Connect via Ethernet if possible
    (You can reinstall Sierra over Sierra. This procedure is no different than installing one OS over another.

    This process should not damage your data but it's always advised that you backup first.
     
  3. andreeasden thread starter macrumors newbie

    andreeasden

    Joined:
    Oct 6, 2016
    #3
    Thanks, I already did that and nothing changed
     
  4. johnmccurdy macrumors newbie

    johnmccurdy

    Joined:
    Jul 19, 2016
    #4
    I came here to see if anyone else has this problem. It seems like a Sierra problem as it had never happened in any previous OS.

    More disappointment from Apple software. :(
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    That is a big clue. Safe mode stops all startup and launch items. So if it works fine in safe mode, it means you have a startup or launch item of some sort that is incompatible with Sierra.

    I would start with this one.

    There is no magic or easy way you pin this down. You just have to keep removing items (listed in the Etrecheck report) until you find the culprit. I like to make a folder on the Desktop then drag these items out of the launch folders half at a time as you test. Print out the Etrecheck report to use as a worksheet.

    The items will be found in these folders as well as the Login Items section of Users & Groups in System Prefs.

    Code:
    ~/Library/LaunchAgents (~ is your users folder)
    /Library/LaunchAgents
    /Library/LaunchDaemons
    /Library/StartupItems
    /System/Library/Extensions/
     
  6. kagharaht macrumors 6502a

    Joined:
    Oct 7, 2007
    #6
    Happned to me twice now since Sierra. Never happened with previous OS. iMac late 2013 purchased 2015, 16gb RAM, i5. ETRecheck shows no issues. OH yeah iTunes just freezes, spinning rainbow wheel unresponsive. I force quit it, then Finder unresponsive I try to force quit it and now just blank screen. No menu nothing, just cursor... so I then Force shut down holding the power button down.

    My other issue is when waking up the Mac its just a blank screen. I turned off wake with Apple Watch and that hasn't happened since, but this freezes is so annoying. It's like the old Mac OS 9 and back days. I thought we were past these things. Sierra just brought this all back.
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    Did you test with a safe mode boot?

    https://support.apple.com/en-us/HT201262
     
  8. kagharaht macrumors 6502a

    Joined:
    Oct 7, 2007
    #8
    No because my iMac also serves as my iTunes server for the family at home. They all stream music, movies and such from it to their devices... If I stay in Safe Mode no one can use iTunes...
     
  9. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #9
    I am not suggesting staying in safe mode. What I mean is do a test in safe mode. If safe mode fixes it, then that means you have some third party launch or startup item that is causing this.
     
  10. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #10
    You don't have to stay in Safe Mode. It's for testing purposes and it clears out certain system caches, amongst other potentially beneficial things.
    EDIT: Sorry for the repetitive post. @Weaselboy and I posted at the same time.
     
  11. kagharaht macrumors 6502a

    Joined:
    Oct 7, 2007
    #11
    ok ill give it a try when i get home from work. thanks!
     
  12. rayward macrumors 68000

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #12
    I was having the same problem. I reset PRAM and SMC and it (so far) appears to have been cured.
     
  13. kagharaht macrumors 6502a

    Joined:
    Oct 7, 2007
    #13
    I'm home and checked the logs at the time of the problem. I see this but have no idea what it means. LOL Have iTunes log too a bit long but I think this entry is probably what's telling?

    Oct 7 07:46:29 iMac2015 Finder[436]: assertion failed: 16A323: libxpc.dylib + 74287 [2A901937-48E1-3BF2-83F1-2431156D82B7]: 0x89
    Oct 7 07:58:34 iMac2015 Finder[436]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked
    Oct 7 08:00:39 iMac2015 Finder[359]: assertion failed: 16A323: libxpc.dylib + 74287 [2A901937-48E1-3BF2-83F1-2431156D82B7]: 0x89
    Oct 7 08:05:50 iMac2015 Finder[359]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked


    Oct 7 07:50:11 iMac2015 spindump[409]: Saved spin report for iTunes version 12.5.1 (12.5.1) to /Library/Logs/DiagnosticReports/iTunes_2016-10-07-075011_iMac2015.spin
    Oct 7 07:51:09 iMac2015 iTunes[631]: assertion failed: 16A323: libxpc.dylib + 74287 [2A901937-48E1-3BF2-83F1-2431156D82B7]: 0x89
    Oct 7 07:51:16 iMac2015 iTunes[631]: BUG in libdispatch client: kevent[EVFILT_MACHPORT] monitored resource vanished before the source cancel handler was invoked
    Oct 7 07:52:33 iMac2015 spindump[409]: Saved spin report for iTunes version 12.5.1 (12.5.1) to /Library/Logs/DiagnosticReports/iTunes_2016-10-07-075232_iMac2015.spin
    Oct 7 07:54:25 iMac2015 iTunes[631]: Entered:_AMMuxedDeviceDisconnected, mux-device:1
    Oct 7 07:54:25 iMac2015 iTunes[631]: Entered:__thr_AMMuxedDeviceDisconnected, mux-device:1
    Oct 7 07:54:25 iMac2015 iTunesHelper[435]: Entered:_AMMuxedDeviceDisconnected, mux-device:1
    Oct 7 07:54:25 iMac2015 iTunes[631]: tid:1f6f7 - Mux ID not found in mapping dictionary
    Oct 7 07:54:25 iMac2015 iTunes[631]: tid:1f6f7 - Can't handle disconnect with invalid ecid
    Oct 7 07:54:25 iMac2015 iTunesHelper[435]: Entered:__thr_AMMuxedDeviceDisconnected, mux-device:1
    Oct 7 07:54:25 iMac2015 iTunesHelper[435]: tid:207 - Mux ID not found in mapping dictionary
    Oct 7 07:54:25 iMac2015 iTunesHelper[435]: tid:207 - Can't handle disconnect with invalid ecid
    Oct 7 07:58:05 iMac2015 iTunes[631]: Entered:_AMMuxedDeviceDisconnected, mux-device:2
    Oct 7 07:58:05 iMac2015 iTunes[631]: Entered:__thr_AMMuxedDeviceDisconnected, mux-device:2
    Oct 7 07:58:05 iMac2015 iTunesHelper[435]: Entered:_AMMuxedDeviceDisconnected, mux-device:2
    Oct 7 07:58:05 iMac2015 iTunes[631]: tid:266bb - Mux ID not found in mapping dictionary
    Oct 7 07:58:05 iMac2015 iTunes[631]: tid:266bb - Can't handle disconnect with invalid ecid
    Oct 7 07:58:05 iMac2015 iTunesHelper[435]: Entered:__thr_AMMuxedDeviceDisconnected, mux-device:2
    Oct 7 07:58:05 iMac2015 iTunesHelper[435]: tid:207 - Mux ID not found in mapping dictionary
    Oct 7 07:58:05 iMac2015 iTunesHelper[435]: tid:207 - Can't handle disconnect with invalid ecid
    Oct 7 07:58:34 iMac2015 com.apple.xpc.launchd[1] (com.apple.iTunesHelper.1504[435]): Service exited with abnormal code: 1
     
  14. kim221 macrumors newbie

    Joined:
    Jul 14, 2013
  15. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #15
    What was the outcome of the safe mode test?
     
  16. kagharaht macrumors 6502a

    Joined:
    Oct 7, 2007
    #16
    Nothing happened, but then again I have to be on Safe Mode for several days. When the freeze happens its just random. I mean it doesn't happen right away. The two occasions that it froze is when I did "Add to Library" then the spinning wheel happens and then it happens. Which also causes the finder to be unresponsive. So maybe its not random? Caused perhaps by trying to add to library from an external drive?
    --- Post Merged, Oct 8, 2016 ---
    I don't have that application anymore.
     
  17. rayward macrumors 68000

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #17
    I spoke too soon, my Mac has taken to crashing again (to the white screen). I'm going to restore a mack-up from prior to the upgrade and sit this one out.
     
  18. GPMACR, Oct 31, 2016
    Last edited: Oct 31, 2016

    GPMACR macrumors newbie

    Joined:
    Oct 31, 2016
    #18
    Smae problem here.

    Reboot/shutdown fails in normal env, fine in safe mode.
    • I've removed /disabled most launch elements and am still failing.
    • All apps ahve been updated
    • Have upgraded MYSQL as some people have cited this as a problem.
    • Am still seeing 'abnormal' exit codes

    1. Oct 31 13:04:33 MacBook-Pro com.apple.xpc.launchd[1] (com.apple.Siri.agent[452]): Service exited with abnormal code: 1
    2. Oct 31 13:04:33 MacBook-Pro com.apple.xpc.launchd[1] (com.apple.iTunesHelper.2644[473]): Service exited with abnormal code: 1

    Remaining bar apps are pretty standard bar caffiene, flux and alfred

    Any help gratefully received....

    Remain
    --- Post Merged, Oct 31, 2016 ---
    Hi all. Solved my issue and replicated on another 2015 MBP running sierra.

    Was getting wierd issues and abnormal code 1 issues in logs when trying to shutdown - the shutdown and reboot processes were failing.

    I upgraded MYSQL to the latest version using the DMG, then reset the SMC (didnt bother with the PRAM). Not sure if there werent

    I can now reboot and shutdown - I still get a bit of slowness but its working. Not sure in the Sierra upgrade some permissions werent shagd.

    Hopefully this will help some of you±±±±
     
  19. rayward macrumors 68000

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #19
    The 10.12.1 update cured my crashing issues. Thank the maker!
     

Share This Page