MacPorts Not Working in Snow Leopard

Discussion in 'macOS' started by holden57, Aug 30, 2009.

  1. holden57 macrumors member

    Joined:
    Jul 18, 2009
    #1
    After upgrading to 10.6 Snow Leopard no longer works. I tried following some earlier tips to get it working, uninstalled it, and then tried installing it again using the .dmg made for Snow Leopard from the MacPorts website. However it still does not work. Has anyone had the same problem? Do they think they could help me?
     
  2. ir0n macrumors newbie

    Joined:
    Oct 24, 2008
    #2
    What exactly is the problem ? I installed MacPorts on clean Snow Leopard install ( 32 bit kernel ) and I haven't encountered any problems except with few non relevant packages.
     
  3. holden57 thread starter macrumors member

    Joined:
    Jul 18, 2009
    #3
    Well perhaps that may just be my problem, but I'm not exactly sure. I tried to install gedit and WINE, but neither one of those would work. Maybe I messed up something when I first installed it.

    Do you know how I can fix it? Or if I can see if something is messed up?
     
  4. ir0n macrumors newbie

    Joined:
    Oct 24, 2008
    #4
    copy paste error log for some clues. gedit is gnome application, you will need to install lots of dependencies to use it ( xorg, gtk etc... ) - are you sure you need it in mac osx ? instead of wine you should try darwine ( though i'm not sure it is tested on SL )
    http://www.kronenberg.org/darwine/



    just checked google and it seems that people run latest darwine on SL just fine. check here:
    http://code.google.com/p/darwine-builds/issues/detail?id=3#c4
    download here:
    http://www.hpoley.dds.nl/darwine/Darwine-x86-1.1.27.dmg
     
  5. doobs macrumors regular

    Joined:
    Jul 19, 2008
    #5
    Make sure that you have Macports 1.8.0 installed. It works fine for me, except for some issues with specific ports running on Snow Leopard.
     

Share This Page