Macports

Discussion in 'Mac Apps and Mac App Store' started by memco, Dec 7, 2008.

  1. memco macrumors 6502

    Joined:
    May 1, 2008
    #1
    so I ran the package installer available from macports, and it doesn't seem to have installed correctly. Whenever I run ports, it says command not found. Any idea why? Also, which do you guys prefer fink or ports? Should I just use both?
     
  2. AussieSusan macrumors member

    Joined:
    May 29, 2006
    Location:
    Melbourne, Australia
    #2
    Just checking the obvious - have you updated your path to include '/opt/local/bin' (or whatever - going by memory here) as described in the installation notes? Macports places itself and all of the packages it provides within this separate tree.

    You also have to alter the 'manpath' if you want the man pages about Macports and any installed software to be made available.

    Susan
     
  3. funkboy macrumors regular

    Joined:
    Apr 25, 2008
    Location:
    elsewhere
    #3
    The command is sudo port. Personally I prefer MacPorts because I have a BSD background (well, and OpenStep...). Fink has a lot more prebuilt binaries available though. MacPorts is not for the impatient <grin>. I'd suggest not using both as it will be a mess with packages from both systems installed. Just use whichever one with which you're more comfortable.

    The MacPorts guide is guide.macports.org and is pretty good.
     
  4. memco thread starter macrumors 6502

    Joined:
    May 1, 2008
    #4
    Thanks, I got it working. Needed to get my .profile setup right. The reason I asked about fink/port is there's a new app called whohas, which crawls both for packages, and I was curious why you'd want to use both.

    Now, on to the whole point of this whole thing anyhow: GIT!
     

Share This Page