GameGuru38

macrumors regular
Original poster
Sep 7, 2009
146
9
Ohio
I can not get my Mac Mini to boot my USB flash drive, it sees it and lets me click on it's arrow to start it but then it just loads Lion 10.7.5 from the system disk. Here is what I have done:

1. Purchases Mountain Lion from the Mac App Store, downloaded it on my wife's 2010 Mac Mini and copied it to my 2007 Mac Mini's Applications folder.
2. Using Disk Utility I created one partition, GUID and formatted.
3. Using MacPostFactor 2.0.1 I created the install disc as 64-bit EFI and it finished.
4. Rebooted Mac Mini holding OPTION and got to the drive select screen, chose my USB thumb drive and clicked on the up arrow and it started to load but then my 10.7.5 system install loaded instead.

Decided maybe something was wrong with the creation so did the exact same steps again but it loaded 10.7.5 system install again instead of booting USB thumb drive.

Redid steps again but this time on STEP 3 I chose 32-Bit EFI instead of 64-Bit EFI to see if it made a difference. Still booted to 10.7.5 system disk.

Repeated again but this time on STEP 2 I tried MBR instead of GUID. Exact same thing!

What am I doing wrong?
 

GameGuru38

macrumors regular
Original poster
Sep 7, 2009
146
9
Ohio
Create the installer using DiskMakerX on your wife's Mac.

I am currently creating it on my wife's Mac Mini but using MacPostFactor since it needs that so it will work on a Mac Mini 2007, but good call. It isn't working on mine for some reason so now trying it on hers.

Will keep you posted!
 

GameGuru38

macrumors regular
Original poster
Sep 7, 2009
146
9
Ohio
Ok I did it on my wife's computer, inserted it into mine and it says it is not readable but this computer.
 

GameGuru38

macrumors regular
Original poster
Sep 7, 2009
146
9
Ohio
When I plugged the USB drive in.

** UPDATE **

OS X Mountain Lion is installed!

But .. I don't think the graphics driver is installed for some reason. Browsers are flashing their content and scrolling is slow. Do I need to do something else?
 
Last edited:

GameGuru38

macrumors regular
Original poster
Sep 7, 2009
146
9
Ohio
Ok is says no Kext loaded, I thought this process was automated with MacPostFactor. How do I get the GMA950 drivers installed on my Mac Mini 2007?
 

Mainyehc

macrumors 6502a
Mar 14, 2004
659
204
Lisbon, Portugal
[bump]
What the hell is wrong with MPF 2.x? This thing doesn’t seem to work with El Capitan… They do warn it’s experimental, but it seems to be all but abandoned at this point.

I’m trying to remake the boot drive using createinstallmedia instead of DiskMaker X and will try and patch it with MPF, but seriously, did any of you guys succeed with this?

I’m trying to install El Capitan on a MacBook4,1, but was trying to boot from the USB installer also on a last generation white MacBook and had the same issue, so clearly the installer was screwed in some way, even though MPF gave a success report. Also, the coding on that thing is so lousy that it can’t detect your installer unless your boot volume is named “Macintosh HD”, just… wow.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.