MacPro 1,1; 10.10.5; GTX 950 Fail

Discussion in 'Mac Pro' started by Kuzbad, Nov 23, 2015.

  1. Kuzbad, Nov 23, 2015
    Last edited: Nov 23, 2015

    Kuzbad macrumors member

    Jun 11, 2009
    I've been having a rough time figuring out what's going on.

    I have a MP 1,1 that's been running Yosemite 10.10.4 with an EVGA GT 640. Today I installed web drivers and swapped in a stock EVGA GTX 950 along with a new 4K monitor (the point of this whole exercise). All worked except I couldn't get 60Hz--only 30Hz. I installed 10.10.5 and updated the web drivers to 346.02.03f02.

    Ignore the following--I fixed the "no video" problem by deleting an NVDAEnabler.kext kernel extension that was on my system. Now just need to get the proper resolutions!

    Now I can't get any video at all. I can VNC in just fine and the drivers seem to be loaded. I've tried DVI, HDMI, and DP with no luck.

    Kextstat shows:

    System Profiler shows:

    "Unknown nvidia card"

    To make matters worse, when I put my old GT 640 back in, the computer never boots to desktop and gets caught in some kind of boot loop.

    Any thoughts as to what might be going on or what I might try? I'm about ready to throw in the towel and go Hackintosh...
  2. Kuzbad thread starter macrumors member

    Jun 11, 2009
    Ok, I managed to fix the worst of the issues--no video. It all came down to an errant kext being present on the system--NVDAEnabler.kext. Once I deleted it, my old video card worked again and my new GTX 950 is up and running! Not sure where it came from...

    My new monitor is an Asus PB279.

    Now the only problem is I still can't get 4k video. The "Display" settings only shows me 1920x1080 and 1280x720 as options (60 hz both). I downloaded a program called SwitchResX and it lets me go up to 3840x2160 @ 30hz--still not 60hz.

    I'm using a DP 1.2 cable from Monoprice (and also tried one that came with the monitor).

  3. Kuzbad thread starter macrumors member

    Jun 11, 2009
    I'm feeling stupider by the minute...this monitor only supports DP 1.1 out of the box and has a OSD menu setting buried about 3 levels deep to enable DP 1.2. Why...
  4. devon807 macrumors 6502


    Dec 31, 2014
    Hello, did the GTX 950 need external power, eg: a 6-pin power connector, or was it motherboard powered?
  5. Thessman macrumors regular

    Dec 8, 2005
    Seems like an interdepartmental communication failure of the monitor producing firm!:p
  6. petelugo macrumors newbie


    Aug 18, 2015
    I am coming in way late - this is really for who ever sees this post or wants 4K at 60 htz. You need an Active Display Port Adapter on any Mac Pro. I have a 2008 w gtx 980 and 2012 w gtx 1080 both run 4K at 60 htz 4444 color HDR but I use an active DP adapter to hdmi.
    Only way I've found it to work. Or Active DP to DP they're easily $30+ For adapter or cable. Anything cheaper that is not "Active" doesn't work
  7. Synchro3 macrumors 68000


    Jan 12, 2014
    You should have read the manual. :)

    I've got the same Asus PB279, no problems with 4K resolution.

    Note that only the two DisplayPorts support 4K @ 60 Hz, the three HDMI 1.4 ports do only support 4K @ 30 Hz.

Share This Page