MacPro 1.1 + Windows 10 + GT 730 + Fireface 800

Discussion in 'Windows, Linux & Others on the Mac' started by hannasdeli, May 17, 2018.

  1. hannasdeli, May 17, 2018
    Last edited: Oct 14, 2018

    hannasdeli macrumors newbie

    Joined:
    Feb 27, 2007
    #1
    After several weeks fighting with my own ignorance on all things Windows, today I feel very proud that I revived my old trusty Mac Pro 1.1 from 2006 for music production purposes. The machine works as the first day, runs Cubase 9.5 without breaking a sweat and handles a lot of plugins easily. I bought it as a demo unit from a store back in 2007, then I had it rendering videos, Motion Graphics and 3D non-stop for years. Finally it doubled up as a Digital Audio Workstation until a couple of years ago. And today it returns to the center of my studio for at least some years more.

    Specs: Stock Mac Pro 1.1, 9GB ram, 250GB SSD Samsung Evo. 7300GT gpu. RME Fireface RME800 + Cubase Artist 9.5.

    These are some small notes that might be useful for someone following the same path.

    1) Upgrade from Windows 7 to Windows 10: I decided to follow the upgrade path instead of the native install. I made a bootable USB stick with the Windows 10 installer with the app called Rufus. Super easy and awesome app.

    Then I run the installer (EDIT: Started in Windows 7, browsed to the stick and clicked on the install app there. The USB drive needs to be bootable to be able to restart and continue the installation from there. The Mac Pro 1.1 won't start the installation by booting from a bootable Windows 10 USB stick) and everything worked well. I let Windows 10 update itself and amazingly enough my computer still had the stock Geforce GT7300, which apparently was already **** when released. Windows 10 runs well with that card. You might need some end of life Nvidia drivers: https://www.geforce.com/drivers/results/82701

    2) Graphics card upgrade to Geforce gt 730. Since I plan to upgrade to El Capitan too I decided to upgrade my graphics card a tiny bit. Despite everything working fine visually on windows, I could appreciate poor color rendering for youtube videos, it looked pretty bad and I think the card reached some limits there, specially fullscreen.

    I went for one of the cheapest Geforce GT 730 I could find, from Asus, with 1GB and cost me 50€ new. It is not a great card but works, does not require extra power cables or anything as it takes the power from the PCIe slot. Also it is fanless and therefore very silent.

    In theory this card should run El Capitan without a problem, probably using the web drivers from Nvidia. I have not tested it yet. It will NOT show the bootcamp bootloader with the different drives and partitions etc, so you will have to memory the positions when restarting. [EDIT: Or even better, use the Bootcamp tools both in OSX and Windows to be able to restart specifying in which drive/partition you want to start next time]


    To install the Geforce gt 730 it, I tested all this:


    a) Replaced the old 7300 with the 730. Unfortunately the computer would do some boot routine but show a black screen. Strange because I only had a windows partition at that moment, it was just a matter of pressing alt for the bootloader just around the chime sound and then press enter.

    I thought the new card was Dead on Arrival.

    b) I put the 7300 back in place and move the 730 to another slot. I could boot without problems and then in device manager I could see the 730 listed in the device tree, but it had a warning symbol. It was not toast! Apparently, and this is a trick, you need to install the Nvidia drivers for that card as it will not boot even in low resolution as most other cards I have used. You can put a card without drivers and it will work, not this one or at least I did not manage it. You need to install the driver first with help from the other card.

    c) Once the drivers were installed I added a bootable drive with Snow leopard and started on that OS. And then a small app from OSX opened and helped me configure the PCIe slots data bandwidth. Apparently there is just so much bandwidth that is shared among the slots. I chanced and gave a full 8X speed to the slot where I was intending to have the card. The gt730 worked in all PCie slots I tried, from the lowest one to the top one.

    d) I removed the old GT 7300 and tried to boot in Windows 10 and the same problem came up again. Black screen no boot. To debug it tried the rEFInd Bootloader (http://www.rodsbooks.com/refind/). It was very easy to create a bootable USB drive with it. Unfortunately it will not show the icons with the GT730 because it does not have the GPU drivers to do so. So I reverted to the old method of "selecting the boot drive by sound" and somehow it started working again and was able to boot in Win10 with the 730GT.

    It was a bit messy the whole process to be honest. A lot of swapping cards.

    3) Adding bluetooth and Magic Mouse 2: This is a work in progress and was a bit nightmare too. I purchased an ASUS USB BT-400. It was just random purchase, did not know it was going to work at all. The key lessons i learned:

    a) The ASUS dongle works. Just install the drivers
    b) Pairing the Magic Mouse 2 is less straightforward: You can only pair it via BT while connected via USB with the provided lightning cable.
    c) The mouse appears at the moment as HID device, I have not managed to install the Bootcamp drivers for scrolling, etc
    d) Scroll is not working for the moment.
    e) I tried the Magic Mouse utilities from this page: https://magicutilities.net/magic-mouse/download and never got them to work, and I just discovered that what you download is a demo and you need to purchase it.

    EDIT Nov 2018:
    I have the Magic mouse 2 working perfectly. It required the new version of Magic Utilities and also tinkering in the Registry and manually enabling Horizontal and Vertical scroll. The method is somewhere in the net. Basically requires you to find the ID of the mouse in the Device Manager of windows and then finding it in a specific folder in the registry and changing the values of VScroll and HZscroll to 1 instead of 0.

    4) The big nightmare: Audio Dropouts for all apps including youtube.

    a) Windows 10 works pretty well out of the box with the Mac Pro 1.1 as it installs drivers for most stuff. I installed Driver Booster, an app to upgrade drivers. Apparently it worked and updated some drivers... BUT there were some crazy audio drops that I did not have before. It made impossible to work with audio or even listening to youtube videos. Removed Driver Booster after a while.

    b) To cut to the chase: The main issue I had was that I did not install the Bootcamp drivers properly. You need to download the Bootcamp Windows Support tool version 5. When you try to run setup it will tell you that your machine is not supported. It somehow detects that you are running a 64bit OS in a machine with a 32Bit EFI or something like that.

    There is a folder labelled as 64bit there with drivers, and you can double click on them to install them one by one. But the right method (that i found in some blog after a lot of searching), the one that really solved most of the problems was to

    - Open CMD in windows by searching CMD, then right clicking on the icon and Run as Administrator. Then you somehow need to navigate to the folder where you unpacked the Bootcamp Tools and run the 64bit installer from the terminal just writing BootCamp.msi. Otherwise it will not run. When you do that the program will install all the drivers.

    The same happens with the Bootcamp tools itself. I managed to install it and then I could chose things like which partition to boot into on restart. No more boot problems.


    This was not the blog i found but they explain it well: http://tsentas.net/bootcamp-x64-unsupported/

    c) Restarted the computer and things worked better... but still some crazy drops.

    d) I tried the LatencyMonitor app. It gave useful information on the latency... but it showed that my computer was more than apt to run audio in real time. In the Driver tab I found that

    - Nvidia and DirectX drivers (Nvidia Kernel Mode driver among them)
    - ataport.sys
    - And the wdf01000.sys driver. This will show a high DPC count but it is not a driver in itself, it is an indicator that some drivers are conflicting, but not which ones.
    - And some others.

    were the main suspects. But their latency was not too high either. The drops were driving me crazy at this stage.

    e) I researched and thought the Spectre vulnerability patches in practice slow down your computer. I found this tool to disable the patches (at your own risk): https://www.grc.com/inspectre.htm. This did not reduce the dropouts.

    f) I finally installed the windows performance recorder and windows performance analyzer tools to try to get down to the issue. Basically you open the first, press record with your music program and it saves a large file with all types of logs. Then you stop and open it with the analyzer tool.

    You basically need to click on the left column to get the following report:

    Computation > DPC/ISR Duration by module. Then you double click and it will open some charts in the main window. The first drivers on the top are probably the ones conflicting. For me it was the OHCI 1394 driver (of which I had tested 3 different versions including the legacy one).

    g) Finally I installed this strange app called Windows Tweaker 4. It has the most random collection of Windows tweaks and improvements... and in the performance section they have one that is something like Disable SearchIndexing. Apparently that is a process that indexes stuff in the background. I disabled it.

    Then i restarted and readjusted my firewire cable... and now the drops are gone after 3 or 4 crazy weeks trying everything. No dropouts whatsoever! Whoooohoooo! The problem is i disabled SearchIndexing and readjusted the firewire cable to my audio card at the same time, so I don't know what was the actual solution.

    Now my MacPro1.1 runs Cubase Artist 9.5 (and the Pro too, of course) without issues, not a single drop even at very low buffers (128 and so) and short latency (7ms and less).

    This computer has a lot of life on it still. Next stage, upgrade firmware and go octocore with new Xeon processors.

    EDIT 2 - November 2018
    - Mac Pro 1.1 runs Cubase Pro 9.5 and the latest plugins without much problems. When you use really powerful compressors and stuff from Acustica Audio (like the new compressor Viridian) it starts to choke a bit. Probably a new macbook pro would take several instances, I don't think the Mac Pro 1.1 quad core can do that.

    - Another useful trick related to Cubase' eLicenser USB. If you attach the dongle to the back of the mac pro for some reason everytime you restart the computer it will not be recognized and you need to unplug it and plug it again to be able to start Cubase. That is SUCH a bummer... BUT I FOUND THE SOLUTION! With an old USB mac keyboard (the aluminium ones with white keys that have two USB inputs in the back) you can plug the eLicenser in one of the USB's and it will work perfectly, without needing to plug it out and plug it in again!

    Also, on the other USB exit of the keyboard I have the Asus Bluetooth dongle and works also perfectly, perfect size too, and it allows to have better reception from the mouse => smooth operation of the mouse.
     
  2. andrew nz macrumors member

    andrew nz

    Joined:
    Feb 11, 2017
    Location:
    Christchurch new zealand
    #2
    hello could you walk me throu0gh the win 10 boot procedure.
    I have tried to create many usb installers with various methods and cannot get a working usb booter although the usb is filled with the correct files.
    The goal is to install windows 10 from a modified iso or perhaps stock iso onto a Mac Pro 1.1
     
  3. hannasdeli, Oct 11, 2018
    Last edited: Oct 11, 2018

    hannasdeli thread starter macrumors newbie

    Joined:
    Feb 27, 2007
    #3
    I am sorry if I did not explain myself 100%. You need to have windows 7 installed on the computer, otherwise I do not think it is possible to actually install windows 10 on a blank mac pro 1.1 without some hacks. Unfortunately I do not remember very well how to start the upgrade procedure... I guess I made the usb stick with rufus and then started in Windows 7, browsed to the USB stick and run the windows installer by clicking on it.

    As i said, you cannot stick the USB with windows 10 and expect the MacPro 1.1 to boot from there and run the installation.

    Here is the tutorial about Rufus and Windows 10 in an USB

    https://appuals.com/how-to-create-windows-10-bootable-usb-using-rufus/
     
  4. Argyboy macrumors member

    Argyboy

    Joined:
    Feb 26, 2017
    Location:
    Dublin, Ireland
    #4
    Just as a note to this - I actually had success installing Windows 10 on my 2.1 by starting the installation on another computer - once it gets to the first restart, shut it down and then move the drive into the Mac Pro. It continued the installation fine.
     

Share This Page