MacPro 3,1 with GTX 970 and Bootcamp issues

Discussion in 'Mac Pro' started by mfletcher, Mar 13, 2017.

  1. mfletcher macrumors newbie

    Joined:
    May 10, 2009
    #1
    Hi,

    Im having an issue with my MacPro 3,1 in Bootcamp when using a MacVidCards flashed GTX 970 card. Ive emailed MacVidCards separately, but I thought I would try here in case someone has a similar setup and has managed to resolve the issue.

    Configuration
    MacPro 3,1
    Video Card: NVidia GTX970 flashed at MacVidCards
    OS: 10.12.3

    Issue
    When trying to boot Windows 10 in Bootcamp, all I get is a black screen.

    Investigation so far
    1) Ive been able to install OSX 10.12.3 with the GTX970 installed and I see no issues in OS X. Im able to boot into OSX, install the NVidia drivers. Everything works fine in OSX - no troubles there.
    2) When I try to use bootcamp assistant to setup windows on a separate drive, with the GTX970 installed, the system reboots and I get a black screen. No flashing cursor. Keyboard is responsive (cap lock key lights when pressed). Nothing else.
    3) When I try to use bootcamp assistant to setup windows on the same drive as OSX is installed, with the GTX970 installed, the system reboots and I get a black screen. No flashing cursor. Keyboard is responsive (cap lock key lights when pressed). Nothing else.
    4) I have a spare Mac Pro 4,1 flashed to 5,1 lying around. Ive installed the GTX970 in that computer and have installed OSX 10.12.3 on it. I see no issues with OSX here, Im able to install the NVidia drivers. Everything works fine in OSX - no troubles there.
    5) On the spare Mac Pro 4,1 flashed to 5,1 , with the GTX 970 installed, I can use the bootcamp assistant to install Windows 10. The system reboots and the Windows 10 installer appears. I can continue to install Windows 10 normally.
    6) I have a spare NVidia GT120 lying around. I install it in the MacPro 3,1. I verify that I can boot to OSX just fine with this card installed.
    7) On the MacPro 3,1 with the GT120 installed, I attempt to use bootcamp assistant to setup windows 10 on a separate drive. The system reboots and the Windows 10 installer appears. I can continue to install Windows 10 normally.
    8) I remove the GT120 from the MacPro3,1 and install the GTX970. I attempt to boot into Windows, but get a black screen. No flashing cursor, again keyboard is responsive.
    9) I install the GT120 into another PCI-E slot and connect the monitor to it. I have the GTX970 in one slot, the GT120 in another I attempt to boot into Windows, but get a black screen still.
    10) Is it a PRAM issue? I reset PRAM and attempt to boot into Windows, but get a black screen still.

    Im not sure what the root cause is here. It appears that the card is physically fine, but is incompatible with the MacPro 3,1 when using bootcamp.
     
  2. Filin Contributor

    Filin

    Joined:
    Mar 7, 2010
    Location:
    Ukraine
    #2
    try install non-uefi version of Windows, like Win7 32bit (x86)
     
  3. mfletcher thread starter macrumors newbie

    Joined:
    May 10, 2009
    #3
    Downloaded Win 7 32bit - tried to install - same result. Black screen - no flashing cursor at all.
     

Share This Page