MacPro 5.1 FCPX slow performance

Discussion in 'Mac Pro' started by bronto11, May 27, 2019.

  1. bronto11 macrumors newbie

    bronto11

    Joined:
    May 27, 2019
    #1
    I'm having slow export speeds. It seems that FCPX is not utilizing GPU.
    BruceX export takes ~43sec. This is how much Vega 64 is used (see attached screens).

    The same is with Compressor. And it doesn't matter if it's transcoding from Prores to Prores or h264.
    Tests were run on OWC Accelsior E2.
    What could the problem be?

    MacPro with Pixlas mod:
     

    Attached Files:

  2. fhturner macrumors 6502

    fhturner

    Joined:
    Nov 7, 2007
    Location:
    Birmingham, AL & Atlanta, GA
    #2
    Unless you’ve implemented some kext patching and boot arguments, you won’t see H.264 or HEVC acceleration from Radeon RX or Vega GPUs. So exporting will be almost entirely by CPU and won’t be improved by the GPU upgrade.

    Your BruceX performance isn’t great, but if you are exporting H.264, that will certainly add time to it. Usually best to export to ProRes instead, so that you are only testing GPU performance during the render.
    --- Post Merged, May 27, 2019 ---
    If you want to see further FCPX improvement, you should run some tests of rendering performance with numerous filters and effects. Pick a good clip or set or clips and compare render performance on your original card and the new Vega. You should see substantial increases in several tests, especially ones like Gaussian Blur and I think color corrections.
     
  3. bronto11 thread starter macrumors newbie

    bronto11

    Joined:
    May 27, 2019
    #4
    Thanks for the input!

    Actually I was exporting to Prores422Lt, so I thought the results should be better and not 43 seconds.
    And CPU usage is very low too.

    There are several examples in this forum where similar configurations give much better results.
     

    Attached Files:

Share This Page

3 May 27, 2019