MacPro 5.1, games won't start after Mojave upgrade.

Discussion in 'Mac Pro' started by pgilmore7, May 28, 2019.

  1. pgilmore7 macrumors newbie

    Joined:
    Sep 5, 2018
    #1
    After installing Mojave on my MP5.1 my games won't start, I get an error message stating, Error: Could not init 3D system. Shader Model 3.0 required. Anyone have this issue? Im running a NVIDIA GeForce GTX 580 GPU, everything else seems to be running fine. Any help would be appreciated.
     
  2. tsialex macrumors 601

    tsialex

    Joined:
    Jun 13, 2016
    Location:
    Brazil
    #2
    GTX 580 is not one of the NVIDIA GPUs that have Mojave support. It's a Fermi GPU, Apple native NVIDIA drivers are made to support Kepler NVIDIA GPUs like GTX 680/780, GTX TITAN, TITAN BLACK, Quadro K5000.

    With a GTX 580, the last macOS version that fully support it is High Sierra.
     
  3. pgilmore7 thread starter macrumors newbie

    Joined:
    Sep 5, 2018
    #3
    Thanks for the info, I was afraid of something like that. I guess its time for a GPU upgrade.
     
  4. h9826790 macrumors G5

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #4
    Yeah, if you love 580, it's time to go for a AMD RX580 :D
     

Share This Page

3 May 28, 2019