MacPro 5,1 Max refresh rate?

Discussion in 'Mac Pro' started by zeeton, Jul 28, 2017.

  1. zeeton macrumors newbie

    Joined:
    Jul 28, 2017
    #1
    Hi all,

    Just got a Nvidea Geoforce GTX 1080 Ti for my 5,1. All good.

    Hooked up a 40" 4k TV as a 3rd monitor (output monitor for video editing). Outputting from the DisplayPort using a Displayport to HDMI cable (can't use HDMI output as Premiere won't send signal through it). All good.

    I get 60hz in 1080HD. All good.

    However, I am maxing out at 30hz in 4k. Both GPU and TV can handle 60hz at 4k. I tried 2 HDMI cables that are both rated for 60hz, and nothing changes.

    I'm wondering if my MacPro and/or Sierra (10.12.5) can't handle 60hz @ 4K. I don't know where else the bottleneck would be.

    Any feedback would be appreciated. Thank you!
    Paul

    I'm running:
    Mac Pro (Mid 2010) 5,1
    2 x 2.4 GHz Quad-Core Intel Xeon
    26 GB 1066 MHz DDR3
    NVIDIA GeForce GTX 1080 Ti 11263 MB
     
  2. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    You need a DP to HDMI ACTIVE adaptor to get 4K 60Hz HDMI signal.
     
  3. zoltm macrumors newbie

    Joined:
    May 9, 2017
    #3
    Would it require the SwitchresX utility too?
     
  4. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #4
    I think so, but not 100% sure.
     
  5. zeeton thread starter macrumors newbie

    Joined:
    Jul 28, 2017
    #5
    Thanks for the input. I've tried several combinations of cable / adapter, including a 'HDMI 2.0' cable connected to a 'Active Displayport to HDMI2.0' adapter. No luck with any of these.

    I'll look into that 'SwitchresX utility'; but I would have thought I could do this without additional utilities...
    Am I missing something here?

    Thanks!
     
  6. xactoman macrumors member

    Joined:
    Jul 9, 2015
    #6
    You have to connect with displayport to displayport. As soon as HDMI comes in, it drops to 30hz on macintosh.

    I have a GTX 1080 and can run a 100hz 21:9 monitor via displayport. 60hz on a 4k monitor. No do with HDMI
     
  7. NY Guitarist macrumors 65816

    NY Guitarist

    Joined:
    Mar 21, 2011
    #7
    ^ Yup, this.
     
  8. carpsafari Suspended

    carpsafari

    Joined:
    Sep 13, 2015
    Location:
    the Netherlands
    #8
    Apple does not support 4K HDMI 60hz...30Hz max, so you need Displayport.
     
  9. DPUser macrumors 6502a

    Joined:
    Jan 17, 2012
    #9
    SwitchResX did the trick for me... DP > Active Adaptor > HDMI + SwitchResX = 60Hz 4k.
     
  10. zeeton thread starter macrumors newbie

    Joined:
    Jul 28, 2017
    #10
    I'm testing SwitchResX right now to see if I get the same result: did you have to modify the System Integrity Protection to get 60hz 4K? I do not see it as an option on the resolutions offered.
     
  11. hc10m macrumors newbie

    Joined:
    Jan 17, 2008
    #11
    After so many trial and errors I got my Macvidcards flashed GTX 780 6G to display 4K at 60Hz succesfully.

    Firstly I bought Club 3D displayport 1.2 to HDMI 2.0 UHD http://www.club-3d.com/en/detail/2366/displayportt-1.2-to-hdmit-2.0-uhd-active-adapter/.

    Secondly, I bought the HDMI 2.0 cable which specified 18Gbps (I tried many hdmi cables I got before but none of them work at all, beware as many others say highspeed hdmi but most of them only to 14Gbps, you have to make sure it says 18Gbps or there is a certification like this http://www.hdmi.org/manufacturer/premiumcable/Premium_HDMI_Cable_Certification_Program.aspx )

    Thirdly, i tried 3 HDMI ports in my LG 40inch 40UB800T, only port 1 and 2 works at 4K60Hz, as specified in the manual. My TV model was an old model bought at the beginning of the 4K war many years ago which dont have HDMI 2.0, may be 1.4b I dont know, as it said only supports 4K60Hz 8bit YCbCr 4.2.0. After searhing review in newer LG TV models which sports HDMI 2.0, they can support 10bits 4.4.4 but I dont know if I can tell the different so far I am quite satisfied with 4K 8bits to look at my iPhotos photos, so gorgeous as you can see all the details in the photos you never see before, amazing.

    Fourthly, I have to buy SwitchResX and add the custom resolutions 4096x2160 60Hz to make it work as the default only have 4K30Hz.

    Finally, I still have problems of how to make the fonts larger as retina display mode dont show up in the display preferences as others which have 4K or 5K monitors shown. I guess because my monitor is a TV and not recognised by the OS, by the way I am using Mac Pro 5.1 Mid 2010 12cores 2.66Ghz running El Capitan 10.11.6 using Nvdia Web Driver. Anyone who have solved the small fonts problems please help me out how to do so as I am now have to switch back to use 1080p60Hz mode for everyday use as I cant surf the web for such a small fonts at all. Nice to share my story and thanks in advance if any help for the small fonts and menus............
    --- Post Merged, Aug 13, 2017 ---
    Oh, forgot to mentioned that I did success of running 4K60Hz in Bootcamp Window 8.1 two years ago playing Titanfall using only my old DVI to HDMI 1.4b cables, not even use the display port (though I only success at running 4K60Hz on MacOS last week after gave up for two years as I bought the 18Gbps cable massively available in stores nowadays and gave it a try, Bingo!). So after searhing the NVDIA website, it said that for the GTX cards they made their drivers to be able to run 4K60Hz on HDMI 1.4b cable as the transition solution before 2.0 coming, though only at 8bits. So it depends on the driver, Apple have been slow to support 4K on MacOS, so the display preferences need to recognize more TVs as nowadays many people start to realize the once you go to 4K, larger sizes monitor 32inch above make more sense and few of the manufacturers make them plus the prices are shockingly high compared to TVs with larger sizes. It takes some time to get used to 4K 40inch and I have seen people posted in Youtube using 55inch LG OLED as their main computer monitors. I am certain not able to go back to the same old days using 27inch monitor, no way uh uh, only go for bigger than 40inches in the future.....
    --- Post Merged, Aug 13, 2017 ---
    Also the Windows 8.1 dont have problems of small fonts as it can be set at the control panel to scale everything up, I use 200% and all things look good as 1080p display. Hope MacOS did correct this mistake urgently..........
     

Share This Page