MacPro doesn't start up. What's wrong?

Discussion in 'Mac Pro' started by dpavid, Jan 3, 2012.

  1. dpavid macrumors regular

    Joined:
    Feb 17, 2004
    Location:
    Mililani, Hawaii
    #1
    http://www.youtube.com/watch?v=BVcgKML1Cbw

    I shut down my mac over the holidays to avoid work and when I trying the start it up this morning, it failed. Do I have a failed power supply? Other things I can try? Thanks in advance!
     
  2. dpavid thread starter macrumors regular

    Joined:
    Feb 17, 2004
    Location:
    Mililani, Hawaii
    #3
    I tried it all. Nothing start up. I can hear and see the fan start up on the graphics card, LED's light up on the RAM, and then it just stops and shuts down. The white LED on the front next to the power button doesn't even turn on. Any other ideas?
     
  3. AkuskaUK macrumors 6502

    AkuskaUK

    Joined:
    Mar 18, 2011
    Location:
    Shanklin, Isle Of Wight
    #4
    Hi,

    From what i have seen before from this problem is that it could be either the riser cards (one of them may be faulty) or a faulty power supply. The lights indicate where a problem is. Your CPU MAY be the main problem here. Are you able to take it into an Apple store close to you for diagnostics?
     
  4. dpavid thread starter macrumors regular

    Joined:
    Feb 17, 2004
    Location:
    Mililani, Hawaii
    #5
    I dropped it off a few hours ago for repair. We'll see what they say... They're guessing its power supply and hope its nothing else.
     
  5. AkuskaUK macrumors 6502

    AkuskaUK

    Joined:
    Mar 18, 2011
    Location:
    Shanklin, Isle Of Wight
    #6
    Hopefully it is!, Good luck!, Hope for a cheap repair!
     

Share This Page