MacPro internal extra sata ports broken since 10.5

Discussion in 'Mac Pro' started by Maestro88, Feb 13, 2008.

  1. Maestro88 macrumors newbie

    Joined:
    Jul 6, 2007
    #1
    I have a mac pro and according to xlr8yourmac.com and the newertech website, there are four sata ports for your hard drives PLUS an additional two more sata ports directly on the motherboard. Through a complicated and difficult disassembly, it is possible to dissect your mac pro and install their cable which they sell for about $30, and get at the rear of your mac pro housing connectors for these two internal sata ports. In short, it's nothing more than an extension cable that fits into a neat housing at the back of the mac pro. You can then plug up to two esata drives into those jacks and they are basically hooked into the macpro motherboard. I ordered this cable and it worked splendidly since 10.4.8 and for 10.4.9 without any issue (that I could tell). I was even able to raid them together etc etc. (edit to be clear I mean I had two Lacie 500Gb drives with esata, firewire 800, 400 and USB 2 on them).

    When I installed 10.5 it was all broken!! What a disaster. I can't use these drives on the firewire bus (which by the way they work fine on) because I am already tieing up that with other devices and drives. I need these extra two buses, plus they were damn fast before- I guess it's the same bus as the internal drives get.

    I have contacted Lacie - no luck - and also newertech, and did so again today, but so far no luck, and apple, no luck and even submitted a feedback request back when we were on 10.5.1 (just released at that time), and no luck. I hoped 10.5.2 would restore this functionality.

    I was told Apple do not normally go out of their way to kill unintended functionality but could this be the case on this occasion?
     
  2. mrcandy macrumors regular

    Joined:
    Nov 12, 2007
    Location:
    Calgary, AB Canada
    #2
    Maestro - since you discuss 10.4.8 and 10.4.9 I'm assuming you have an original MP? Not sure if it's the same as my 2008 MP, but I had trouble getting the ODD ports to work with an external eSATA enclosure as well. I didn't buy one of the cables you discuss, but I essentially built the same thing from parts.

    It is essential that you connect and power up the external drives before you power up the MP. Once the MP is up and running, should you disconnect the cable and/or power off the external drive, you will not 'see' the external drive again until you cycle power on the MP.
     
  3. Maestro88 thread starter macrumors newbie

    Joined:
    Jul 6, 2007
    #3
    Thanks for your response.

    It's not exactly an original one, it's the sort of 1.2 revisio, which is the 8 core machine, I think there are some small differences... probably not important, but anyway yes, it's not a 2008 model.

    I understand what you say about the drive needing to be powered on at boot time. I have followed that to the letter, and as I said, I clearly had them working well for some time, under a lot of use, with no problems. I think the most likely culprit is either the firmware updater, followed by the leopard update, (less likely) and then followed by an actual hardware problem (least likely given that the other four ports on the same chipset are functioning normally and I did nothing to damage the 2 that are not working.

    The other thing that makes me think it is not an OS issue is that the system will not even boot into a tiger install disc with the drive(s) plugged in.

    Cables are working as, as I said, the lacie drives are actually visible on the desktop, but cause a grey curtain shortly after.
     
  4. mrcandy macrumors regular

    Joined:
    Nov 12, 2007
    Location:
    Calgary, AB Canada
    #4
    From your description below, and in the other thread on here, your problem sounds different than what I saw. With mine it either worked completely or not at all.

    The only other suggestion I have for you, and it's a long shot, would be to physically take one of the drives out of the external enclosure and temporarily mount it inside the MP - connected to one of the ODD ports. The second optical bay is good place to put it if you don't have a second optical drive. You may need a SATA power connector if your drive doesn't have a legacy molex power connector. Also, you would need a normal SATA cable instead of eSATA that you currently use for the external enclosure. This would check a few things, 1) it eliminates the external case controller, 2) uses a different cable, 3) guarantees the correct power up sequence. As I said it's a long shot since you've already checked most of those.

    Best of luck.
     
  5. Neurorad macrumors newbie

    Joined:
    Aug 28, 2006
    #5
    OK for me

    I am using the extra SATA ports on the motherboard for additional internal drives. I have NO problem whatsoever. I have an August 2006 Mac Pro running 10.5.2.
     
  6. Maestro88 thread starter macrumors newbie

    Joined:
    Jul 6, 2007
    #6
    Thanks for the replies.

    I got a reply from Lacie tech support who said that it is a known issue, and that i"m not the only one with this issue but they are trying to find out what it is, and I sent them my system log as requested, we'll see what happens there. It should be noted that I also tried out an external (new) seagate drive to see if that would work - it did not, in fact it crashed the system on startup - nothing but a grey screen. when not plugged in, system started up as normal. I haven't got the time or hardware expertise to take the drives out of those cases, and those drives are still under warrantee.
     
  7. nlpomeroy macrumors newbie

    Joined:
    Apr 15, 2008
    #7
    FWIW - I have two Mac Pros. One is the older model and the extra SATA ports work fine, and one is the early 2008 and these ports do not. Same version 10.5.2. of OS X and same external drives. Looking forward to Apple or someone figuring this out.
     
  8. brand macrumors 601

    brand

    Joined:
    Oct 3, 2006
    Location:
    127.0.0.1
    #8
    I know the two additional SATA ports work but thought that they were not supported by Apple. Am I incorrect in this? If it is the case they could disable the ports with a future firmware update if they choose.
     
  9. jazz1 macrumors 65816

    jazz1

    Joined:
    Aug 19, 2002
    Location:
    Mid-West USA
    #9
    Does anyone know the original purpose of these extra ports then? Why put them in at all?
     
  10. martinlk macrumors member

    martinlk

    Joined:
    Jun 20, 2005
    Location:
    Aalborg, Denmark
    #10
    I'm guessing they are there for users who want to add SATA DVD drives or, in the near future, Blu-Ray drives.
     
  11. distortedloop macrumors 6502

    distortedloop

    Joined:
    Jun 29, 2007
    #11
    MacPro 1.1 here (just about one year old), quad core.

    eSata cables and bracket from OWC.

    Two Free Agent Pro eSATA drives plugged into those ports.

    Absolutely no problems with these two drives in this setup until after OS X 10.5.2 update.

    Now I get random kernel panics and semi regular Finder hangs (that Force Quit can't resolve). I've pretty much narrowed down these issues to the eSATA drives becoming unreadable from the Finder for some unknown reason. Strangely, I can still read and write to the drives after this occurs in Terminal.

    It has always required a restart of the system to get Finder running again.

    It actually seems to happen most often under heavy I/O activity, so it's not that the drives are going to sleep or something like that.

    I tracked down a kernel panic's log and saw an error message about IOSTORAGE and other errors in the system.log related to /dev/disk4s2 being unknown. That disk id is one of the two eSATA FreeAgent Pros.

    This morning I was able to actually recover the system and not require a reboot by just unplugging the external drive.

    This leads me to believe that it is some sort of bug in the Finder drive handling similar to what we used to see when Finder pinwheeled after trying to read a disconnected network drive.

    I thought the problem might be unique to these FreeAgent drives, but apparently not. i do have a third eSATA drive that I put together with a NexStar enclosure that I haven't tried on the system. I suppose I should for further trouble shooting.

    edit: in regards to Finder hanging, it may actually be Finder hanging after an application like Unison stops responding when unable to write to the drives. I think I've been downloading with that app, or Transmission bittorrent, on each occasion this has occurred, but wouldn't swear to that. At any rate, at least twice that this has happened in the last couple of months, I now recall that Unison would not Force Quit either once this happens.
     
  12. brand macrumors 601

    brand

    Joined:
    Oct 3, 2006
    Location:
    127.0.0.1
    #12
    I highly doubt that was their intended purpose otherwise they would have been much easier to access from the optical drive compartment.
     
  13. satori42 macrumors newbie

    Joined:
    Nov 13, 2008
    #13
    Problem solved, sort of

    Thanks for the insight with this problem, I struggled with this for a while with drives occasionally working hooked up to one of the extra SATA ports in my MacPro, but it seemed intermittent, at best. Until I tried what was suggested here: powering up the drive with the MacPro off, and then booting the MacPro. Now I have 2 eSata drives working great (total of 6 sata drives, the four normal internal sata and two eSata drives). :D
     
  14. cepheusfilms macrumors newbie

    Joined:
    Jun 9, 2004
    #14
    Broken on new Octo Mac Pro - 10.5.5

    Hello,

    Same problem here. We just picked up another Mac Pro a couple weeks ago and the two internal SATA ports do not work. The DVD burners we plugged into the ports appear, but they can't read any data.

    Very frustrating. Just picked up an LG Bluray burner and now I need to hunt down an external case. No big deal, but it would be nice if these ports worked again.

    Best,

    C
     
  15. noushy macrumors regular

    Joined:
    Aug 27, 2008
    Location:
    Detroit, MI
    #15
    Ports 5 and 6

    Guys, there is no reason that ports 5 and 6 do not work with 10.5 as my macpro (early 2008) shipped with 10.5.4 and they work. Now you cannot use bootcamp from these ports, but they make great esata ports. If you have a newer macpro, then there may be something wrong with these ports. Earlier I was using these port 5 for my boot drive and the a raid card on the 4 lower bays. Now I use a sff8087 internal cable with 4x sata cable to bring the ports 1-4 up to the lower optical bay. I then use a 5.25 2.5x4 raid drive cage with two velociraptors (300gb one for boot, one for windows). They show up as bays 1 and 2 under the os. I use ports 5 and 6 to an esata pci adapter, and an external two drive esata case from macsales. I use apple software raid to create a raid 1 on the external esata drives and time machine to backup to them. I never turn the external drives off, so I have not had any problems.

    Peace,
    Noushy
     
  16. Nadav35 macrumors member

    Joined:
    May 18, 2008
    #16
    The solution is here!

    I have just been told by an insider, and friend of mine who works in apple engineering that because of the numerous complaints regarding bootable odd ports to be used for windows bootcamp(the odd ports work on the mac side, hard drive, optical..), bootcamp 3.1 will provide many things. Firmware updates which one of them fixes the problem with odd ports not booting into bootcamp/AHCI compatibility is now realized.

    this will be out in December or close to the end of the year. Also 3.1 addresses the issues with win7 and makes all devices compatible with it.

    hope this helps!









     

Share This Page