MP 1,1-5,1 MacPro stuck at black screen at shutdown

superparati

macrumors member
Original poster
Apr 11, 2016
97
14
London
Hello,

My dad shared with me few information regarding an issue he is facing without knowing what is it exactly.

By error he has accepted to install few updates including Itunes, security update and Safari.

At each reboot or shutdown, the Mac displays a black screen with pointer visible and stay for minutes like that 5,10min without doing anything.

I said this might be related to the security update has my dad runs macOS High Sierra with two GPUs GT120 Slot 1 (connected to the screen), R8 380 in slot 2, MP51.0089.B00 firmware

On the Preference System, Update, every single option has been unticked. Nothing can be installed automatically.

First idea:
Because my dad press the install button one time, the system is trying to install something and does not work.
Is there a way to stop the install process at the shutdown?


Thanks
 
Last edited:

superparati

macrumors member
Original poster
Apr 11, 2016
97
14
London
End of the week I have the time to add more information here.
The Mac Pro is running on High Sierra 10.13.6 with the MP51.0089.B00 firmware.
Two graphic card are plug in to the Mac. A GT120 and a R9 380.

The issue happens only when we perform a reboot or shutdown the computer. It reboots /shutdowns not properly.
I've executed the monthly Onyx Script, did a PRAM reset and nothing better.

I'm assuming the MP is trying to do something. I have this black screen with only the pointer visible for a unlimited time.

Tomorrow I'll try to install the Combo at see what is happening.
Also might have a conflict between the two GPUs. So I'll also remove the GT 120.


Any suggestions are welcome.
Thanks
 
Last edited:

orph

macrumors 68000
Dec 12, 2005
1,861
382
UK
is he using a HD or SSD.
may be bad drive
may be a software installed or background demon

some time's the simple and best solution is a clean install of osx.
do back up all data in advance

always worth doing a safe restart first i gess, can fix a lot of problems.

edit
my default is to install a copy of osx on to a USB stick, boot from USB stick and see if i still hit the problem.
-if no it's a software problem or something and will be fixed from a clean instal
-if yes it may be hardware
(if no it may also be bad drive)
 

tsialex

macrumors 603
Jun 13, 2016
5,378
6,090
Brazil
End of the week I have the time to add more information here.
The Mac Pro is running on High Sierra 10.13.6 with the MP51.0089.B00 firmware.
Two graphic card are plug in to the Mac. A GT120 and a R9 380.

The issue happens only when we perform a reboot or shutdown the computer. It reboots /shutdowns not properly.
I've executed the monthly Onyx Script, did a PRAM reset and nothing better.

I'm assuming the MP is trying to do something. I have this black screen with only the pointer visible for a unlimited time.

Tomorrow I'll try to install the Combo at see what is happening.
Also might have a conflict between the two GPUs. So I'll also remove the GT 120.


Any suggestions are welcome.
Thanks
One easy thing to debug/test is to enable verbose boot, when you are shutting down with a GPU that have pre-boot configuration support, it will show the logs too:

Code:
sudo nvram boot-args="-v"
 

superparati

macrumors member
Original poster
Apr 11, 2016
97
14
London
Thank you tsialex and orph for your good advice.

We’ve done some testing removing the Nvidia, switching to a different hard drive.
I boot from a nearly not used and cleaned High Sierra to clone the SSD which at the end works.
However booting from the clone SSD brought the same issue as the beginning.
We ended up to process to a clean install install back manually the software. This last solution seems to have solved the problem.

I won’t be able to understand what cause the issue but at the end no more bugs while shutting down the Mac.
The SSD is in good condition according to DriveDx

I’ll switch later for a newer GC.

Thanks!