MacPro stuck in endless reboot

Discussion in 'Mac Basics and Help' started by Lvanhoff, Oct 21, 2009.

  1. Lvanhoff macrumors newbie

    Joined:
    Jan 31, 2008
    #1
    Hi
    I installed a second hard drive, installed iphotomanager, merged some iphoto libraries onto the new drive and all was working fine. I changed some permissions ("unlocked" all of the drives as the merge was having trouble writing to the new drive but then it worked fine after I unlocked). Then I started getting the message again that it could not write to the iphoto library plist and the merging stopped working. So I thought maybe if i restart the computer, it would sort itself out but noooo, now it won't start.

    It just starts to power up then you hear the drive die down. Tries over and over. So I took out the new drive I'd merged all the iphoto libraries on (which had been working fine until it didn't). But i suspect it had to do maybe with me changing permissions in the middle of the process maybe?

    I tried restarting in safe mode, by holding down the shift key when I heard the start up tone until the grey screen with apple logo and spinning wheel appeared, and it takes longer now, but still ends up trying to restart and never gets to the login screen.

    I have my Mac Pro installation disc 1 but can't find any others.
    I have Disk Warrior 4.0

    But I can't get the disk drive to open since it won't start.

    This is a MacPro Running Mac OS X 10.5.8
    Processor 2.2 INtel Core 2 Duo


    Any ideas? I'm absolutely stuck.

    Thanks so much in advance!
    Laura
     
  2. pdubak macrumors member

    Joined:
    Oct 20, 2009
    #2
    Hold the mouse button between the boot chime and when the gray apple appears to eject your CD drive.

    Boot to the install CD, open disk utility and run repair permissions (since you were changing permissions before it happened), and repair disk wouldn't hurt either. Then reboot and pray. Disk warrior wouldn't hurt either.

    Give that a try, and if your still stuck you may want to consider connecting it to another mac via Target disk mode and backing up then trying an archive install of the whole system :( and checking the box to preserve your files when you select that install option. Immediately run all software updates when you come back up. You'll at least have your data in proper places but I can't promise you'll be back 100% without some additional App reinstalls etc. first.
     
  3. Lvanhoff thread starter macrumors newbie

    Joined:
    Jan 31, 2008
    #3
    thanks...more detail please

    Ok so holding the mouse button down worked to open the drive, thank god I had an old cordless mouse around.

    Put the install CD in but still grey screen, nothing happening but restarting over and over. Anything special I need to do to boot from the CD?
     
  4. Lvanhoff thread starter macrumors newbie

    Joined:
    Jan 31, 2008
    #4
    not working

    I tried holding down the C key as i restarted with Disk Warrior 4.0 in the drive, still grey screen,apple logo, spinning, restart loop. Arrrgh.
     
  5. pdubak macrumors member

    Joined:
    Oct 20, 2009
    #5
    Try holding the "Option" key at startup.

    You should get a list of devices to boot off of. Try selecting the CD from there.

    If your still stuck, i'd try pulling the second drive and go back to the "All Apple" original config. and try again.
     
  6. Lvanhoff thread starter macrumors newbie

    Joined:
    Jan 31, 2008
    #6
    still stuck...

    I've got it now where it will boot with the utility disk, don't know why it let me finally. I ran the repair permissions and repair drive. Says my drive is ok. After an hour it says permissions were repaired. Went to restart from start up disk in disc utility but then it's back to the grey screen and spinning wheel. Still won't boot up.

    I can get to the terminal window in disc utility. Anything to do there? fsck?

    I feel convinced it had something to do with me changing permissions when i was trying to merge iphoto libraries with iphotomanager.
     
  7. Lvanhoff thread starter macrumors newbie

    Joined:
    Jan 31, 2008
    #7
    and

    And I forgot to say that I did take out the new second drive from the beginning, as soon as it wouldn't boot up. So it's just my original Apple stuff.
     
  8. dashcs macrumors regular

    Joined:
    Oct 2, 2009
    #8
    Changed permission

    Two things stick out here.

    One you stated you changed your permissions
    Two,you stated repair disk permission took over a hour.

    Which leads to this question.
    Did you change the permissions on the whole entire bootable drive?
    Like Get Into,apply to enclosed items

    If you just change the permission on the HD without clicking apply enclosed items,you can still resolved that in single user mode
    You Mac HD has special permissions outside of your user folder,you dont mess around with that.

    If you change permissions and apply to enclosed items,you screwed up your bootable drive.


    And you need to re-install,which A&I might even fall...
     
  9. Lvanhoff thread starter macrumors newbie

    Joined:
    Jan 31, 2008
    #9
    uh oh

    Yes i did apply to enclosed items, not knowing what that meant, because iphotomanager was saying it couldn't write to the drive (was going along fine then suddenly had that error) so I thought maybe i needed to do that. That took an hour too by the way and I had that sinking feeling I'd done a bad thing but it wouldn't let me stop it.

    So...now I just plugged in my external hard drive, and it has a locked symbol and says "custom" for the access and I can't get to any of my data there either. It won't let me change it back to read and write.

    I clearly made a mess of this.

    So you are thinking I have to reinstall everything??

    Any other ideas? No way to fix permissions issue in terminal mode?
     
  10. Lvanhoff thread starter macrumors newbie

    Joined:
    Jan 31, 2008
    #10
    also

    I just ran permissions repair again. It took about 20 minutes this time. All of the messages say ACL found but not expected on "System/Library/Frameworks/...then a variety of folders after that.
     
  11. dashcs macrumors regular

    Joined:
    Oct 2, 2009
    #11
    First Disk Permissions..

    In a nutshell,Repair disk permission repair permissions of apple installed programs.

    It won't resolve your issue here.


    Custom access on external HDs is a easy fix.
    Theres terminal commands to fix that which I dont have in front of me.


    If you have APP,I would contact Applecare and asked to be transfer to tier 2.
    Trust me....they get theses calls all the time and they can help you out.
     
  12. Lvanhoff thread starter macrumors newbie

    Joined:
    Jan 31, 2008
    #12
    Fixed

    Installed Snow Leopard, repaired permissions again, used batchmod program to fix the locked drives, and all is well again. Thanks.
     

Share This Page