Macrumors is crashing on iPhone?

Discussion in 'Site and Forum Feedback' started by iModFrenzy, May 3, 2015.

  1. iModFrenzy macrumors 6502a

    iModFrenzy

    Joined:
    Jan 15, 2015
    Location:
    Lead The Way!
    #1
    I keep trying to get on macrumors with my iPhone 1st Gen but it keeps crashing, any way to fix this?
     
  2. iModFrenzy thread starter macrumors 6502a

    iModFrenzy

    Joined:
    Jan 15, 2015
    Location:
    Lead The Way!
    #3
    i tried clearing my cache, I can get on parts of the forum but if I click threads, Safari crashes.

    I'm using iOS 3.1.3.

    I tried the using the debug console. On the front page of MacRumors, the consoles counts about 39 HTML errors. Other parts of the forum, I might get like 2-3 errors.

    It always loads the page but stops midway and crashes back to the home screen.
     
  3. Meister Suspended

    Meister

    Joined:
    Oct 10, 2013
    #4
    I also have an iPad 1 and recently upgraded to iOS 5. I recommend you do the same.
     
  4. iModFrenzy thread starter macrumors 6502a

    iModFrenzy

    Joined:
    Jan 15, 2015
    Location:
    Lead The Way!
    #5
    Can't. iPhone 1st Gen. only goes up to iOS 3.1.3, no further.
     
  5. Meister Suspended

    Meister

    Joined:
    Oct 10, 2013
    #6
    That might be the problem.
     
  6. iModFrenzy thread starter macrumors 6502a

    iModFrenzy

    Joined:
    Jan 15, 2015
    Location:
    Lead The Way!
    #7
    I doubt the phone cant handle it, I mean when I load certain pages of the site, no issues.

    Are there any alternate browsers for iOS 3.1.3?
     
  7. MacRazySwe macrumors 6502a

    Joined:
    Aug 7, 2007
    #8
    MacRumors Forums crashes 3 out of 5 times on my iPad Mini (1st Gen) on iOS 7.1.3 using Safari.

    What's wrong? Turning off JavaScript does not help. Happens in normal browsing as well as "private browsing-mode". Only happens on MacRumors Forums, works well otherwise. Started happening in the last two months or so I believe.
     
  8. iModFrenzy thread starter macrumors 6502a

    iModFrenzy

    Joined:
    Jan 15, 2015
    Location:
    Lead The Way!
    #9
    JavaScript isn't used on MacRumors(except for YouTube videos), HTML is used.

    Normal/private browsing probably won't make a difference.
     
  9. roadbloc macrumors G3

    roadbloc

    Joined:
    Aug 24, 2009
    Location:
    UK
    #10
    Apple want you to buy a new iPhone. It is that simple.
     
  10. MacRazySwe macrumors 6502a

    Joined:
    Aug 7, 2007
    #12
    Okay, I see! :)

    I have followed several threads where people are having the same issue. Most people have suggested to me and others that turning off JavaScript would help, or switching off Private Browsing.

    Hence why I brought it up.

    Anyways, it would be interesting if someone responsible at MacRumors could enter the discussion. I know many of us are having the issue. Even people with A7-gen devices (iPad Air, rMini or iPhone 5S)
     
  11. entropi macrumors 6502

    Joined:
    May 20, 2008
    #13
    test iCab!

    I use iOS 7.1.2 on my iPhone 4 and iPad mini 1. Macrumors forums crashes ALL THE TIME on safari nowadays. My fix is to surf the forums with iCab instead, with adblock on and it never crashes!
     
  12. redheeler macrumors 603

    redheeler

    Joined:
    Oct 17, 2014
    #14
    It does the same on my iPhone 2G, it's probably a bug in Safari on that version of iOS (3.1.3).

    ----------

    Actually, the ads use JavaScript as well as the post upvote buttons.
     

Share This Page