MacRumors Slow

Discussion in 'Site and Forum Feedback' started by thunderclap, Jun 19, 2008.

  1. thunderclap macrumors 6502a

    thunderclap

    Joined:
    Nov 8, 2003
    Location:
    Chicago
    #1
    Has anyone else noticed that last couple of days here on MacRumors has been pretty slow when loading? Or is it just me?
     
  2. Blue Velvet Moderator emeritus

    Joined:
    Jul 4, 2004
    #2
    No, it occasionally chokes up for me too, and it hasn't been as smooth as it has been in the past... but we have been quite busy. We'll just have to stop using that developer's copy of Snow Leopard to run it all on. ;)
     
  3. rpaloalto macrumors 6502a

    rpaloalto

    Joined:
    Sep 19, 2005
    Location:
    Palo Alto CA.
    #3
    Me too
    Recently it has gotten so slow. I have to check other websites just to make sure it's not on my end.
    Nice to know Macrumors is getting the traffic it deserves.
     
  4. donga macrumors 6502a

    donga

    Joined:
    May 16, 2005
    Location:
    AZ
    #4
    you just replied to a post referring to something that is 3 months old
     
  5. iJohnHenry macrumors P6

    iJohnHenry

    Joined:
    Mar 22, 2008
    Location:
    On tenterhooks
    #5
    It's amazing that his browser didn't time-out. :p
     
  6. jbernie macrumors 6502a

    jbernie

    Joined:
    Nov 25, 2005
    Location:
    Denver, CO
    #6
    Actually it has been slow, and seems to be the ads, i get the MacWorld posting part real quick and then it lags while it loads the ads and then the rest loads fine, the ipod pics etc shouldnt be the cause and there is nothing on the home page other than the ads that should load slow.
     

Share This Page