Macs can't connect wirelessly but can connect wired (Netgear DG834G)...

Discussion in 'Mac Basics and Help' started by Ken Masters, Dec 1, 2006.

  1. Ken Masters macrumors member

    Nov 30, 2006
    Hi Guys

    I've searched and searched and searched and tried absolutely everything including PPPoE stuff, random other stuff and still no hope...

    Got my MacBook Pro today and can't connect wirelessly. Internet works fine when plugged in via LAN cable. I've noticed that whenever 'Mac friends' come round they can't connect either so it must be a Mac only problem. Obviously this wasn't really a problem but now I've converted it has become one.

    Router: Netgear DG834G
    ISP: Pipex

    Thanks in advance :)
  2. stoid macrumors 601


    Feb 17, 2002
    So long, and thanks for all the fish!
    What kind of computer do you have? My 1.25 Ghz PowerBook G4 can't connect wirelessly to my roommates D-Link, but my Airport Express plugged into the D-Link can get a signal and so I get my wireless from that.
  3. Ken Masters thread starter macrumors member

    Nov 30, 2006
    I have a brand new 15" MacBook Pro intel 2.33ghz. I don't think the model makes any difference because various other Macs have been unable to connect wirelessly to the internet.
  4. dolphin1 macrumors member

    Nov 12, 2006
    I have an ibook and I have no problem at all getting wireless service. I use it at work and use wireless, I've traveled with it and get wireless service at hotels and such.
  5. Queso Suspended

    Mar 4, 2006
    I used to have a DG834G and never had a problem with it. It may be the way the WEP/WPA keys are configured, since on the Mac the terminology is different to how things are phrased on the router.

    Strip out all security on the Netgear, broadcast the SSID, and allow it to accept all MAC addresses. See if the Mac picks it up and can use the connection. Then one by one add the security options back in to see where the configuration problem is.
  6. Ken Masters thread starter macrumors member

    Nov 30, 2006
    In the end I just rang Netgear customer support (who were surprisingly helpful).

    All I needed to do was change the WEP key to WEP key hex and re-enter the WEP key (ensuring all caps). I was overcomplicating things with PPPoE and DCHP worries when in reality all I had to do was change an option in the connect menu!

    I'm a happy bunny! :)

    EDIT: pretty similar to what was suggested above by dynamicv.
  7. Queso Suspended

    Mar 4, 2006
    Well done. BTW, are you the same Ken Masters that used to wear lots of pastel shades and employ Leo Howard? :)
  8. Ken Masters thread starter macrumors member

    Nov 30, 2006
    No, I'm the guy who will still be playing Streetfighter when I hit my thirties! :D

    Ken Masters

  9. Queso Suspended

    Mar 4, 2006
    LMAO. The fact that I'm thinking of an obscure fictional balding powerboat tycoon rather than such an obvious cultural reference says a lot about my lack of cool :D

    Glad you got your MBP sorted though.
  10. UpsideDownFace macrumors newbie

    Jan 24, 2008
    Netgear DG834PN

    I bought a reconditioned macbook 3 days ago and because my previous router broke down the day before, I bought a NETGEAR DG834PN which works OK with my 3 linux computers.

    The DG834 worked after a while with the ethernet connecion, but kept telling me I had entered the WEP key incorrectly even if I set it to nothing.

    So I entered "macbook netgear WEP" into google and found this forum which told me to put $ before the WEP key.

    This ended 2 days of frustration, by giving me an almost instant connection to the internet.

    So I am happy !
  11. The Void macrumors regular

    The Void

    Oct 29, 2003

    I just had the same problem, and this thread helped. I found adding "0x" before the hex code fixed it for me. Trouble is, my iPod touches, that were previously on the netgear's network now won't connect - 0x or not.

    Anyone know why my Macs will connect but my iPods won't?


    The Void
    Blues for Palmers
  12. The Void macrumors regular

    The Void

    Oct 29, 2003
    Found my own answer:
    iPod - Settings>General>Reset>Reset Network Settings.
    This restarts the iPod, then re-inputting the WEP key made it all work.

    Hope that helps someone.

    The Void
    Clicking wood
  13. Jaxsensei macrumors newbie

    Aug 6, 2009

    Thank you Ken Masters. You have stopped endless hours of swearing!
  14. chrono1081 macrumors 604


    Jan 26, 2008
    Isla Nublar
    I was about to suggest that but you already got it taken care of.

    This isn't a mac only thing, this happens a lot with various types of machines. I wont get into the nitty gritties of why but its always safest to use a hex key over a passcode.

Share This Page