Macs not working with Ricoh Aficio MP 3350

Discussion in 'Mac Basics and Help' started by JKB217, Oct 16, 2015.

  1. JKB217 macrumors newbie

    Joined:
    Oct 16, 2015
    #1
    Our company recently purchased a Ricoh Aficio MP 3350. We have been able to set it up with all of our computers running Windows but cannot get it to work with any of our Macs. We have 4 Macs, one with 10.11 El Capitan and three with 10.10.5 Yosemite. We downloaded the drivers and can add the printer, by searching by IP address. Once the printer is added, everything we print has two lines of random text and then prints dozens and dozens of blank pages. It doesn't stop until we cancel the job.

    I have looked through other posts and saw one about a Ricoh Aficio MP C2500 having similar issues. I attempted to use the links and downloads that worked for that poster but many are out of date and no longer work.

    I called our IT company to assist but they are not familiar with Macs and cannot help in any way. Any help would be greatly appreciated.
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Did you get you drivers from this Ricoh Driver download page? Plus do a reset of the printer in the Print& Fax Preference Pane then add the stupider again! Sometimes this helps.

    Plus just putting the IP of the printer in you favorite browser it will take you to it's wiki setup page on the printer!
     
  3. JKB217 thread starter macrumors newbie

    Joined:
    Oct 16, 2015
    #3
    I did get the riders from the Ricoh Driver download page. I didn't try reseting the print/fax pane but have done it after your recommendation. Unfortunately it didn't solve the issue.

    I put the IP address of the printer in the browser and it brought me to the Web Image Monitor for the printer. I can't easily find anything that points me in the direction of setting up the printer. Any suggestions?
     

Share This Page