Macs suddenly unable to connect to Windows Server

Discussion in 'Mac OS X Server, Xserve, and Networking' started by D93Cid, Jan 22, 2015.

  1. D93Cid macrumors newbie

    Joined:
    Jan 22, 2015
    #1
    We have multiple macs and PCs on a network with a Windows 2000 server.

    We have been running macs on this network since 2008, replacing PCs with macs as we go. Up until a few days ago, everything worked nicely, then the macs could no longer connect to the server. We noticed the problem in the middle of the day. It worked in the morning, and not since.

    The macs are mostly minis, 2 iMacs, and an MBP. All but one of the minis are running Yosemite. The problem is identical for all the macs. The 3 PCs are not affected.

    No changes were made to the server, it stays powered on, but logged off.

    We can ping the server through Network Utility, and we can access the server through Virtual Machines and Microsoft Remote Desktop on the host macs, but not from OSx.

    We are able to see the server in the shared items in finder, but when we click to connect, it says Connection Failed. We have tried connecting as different users with no luck. We also have some alias shortcuts to folders on the server, when we click on those, it runs through the "Resolving alias to..." then asks for user name and password. None of our user names are working.

    I've spent over 9 hours on the phone with Apple, Microsoft, and even VMWare to find a solution, but everyone is stumped and has pointed to the other guys.

    Any help would be appreciated.
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    I found it is better if you go into System Preferences->Date & Time and put in the Microsoft Sever IP in the Time Server section connection box, then restart.
     
  3. D93Cid thread starter macrumors newbie

    Joined:
    Jan 22, 2015
    #3
    satcomer, I don't see an option to set Time Server.

    However, for what it's worth, I grabbed an older mini I got from a friend that is running OSx Lion. Plugged it in, connected to the wifi, turned on file sharing, clicked on the server and entered credentials, and was able to connect with no issues.

    I have checked the other macs we have here and all are set up the same way, but not able to connect.
     
  4. DJLC, Jan 22, 2015
    Last edited: Jan 22, 2015

    DJLC macrumors 6502a

    DJLC

    Joined:
    Jul 17, 2005
    Location:
    Mooresville, NC
    #4
    Are the Macs bound to Active Directory?

    If so, unbind and re-bind. And be sure the time on the Macs matches that of the Windows server as suggested above (before attempting any bind operations).

    Otherwise I haven't a clue. Do you have automatic updates enabled on the Macs? Perhaps Apple pushed an update that, for whatever reason, broke file sharing with Windows Server 2000. It has been EoL software for a while now. You can check update history in the App Store.
     
  5. D93Cid thread starter macrumors newbie

    Joined:
    Jan 22, 2015
    #5
    Problem solved!

    Per your suggestions, I simply changed the time on the server to match the time on the macs. Voila! Everything is now working as it should.

    It is odd, though, the Windows server and PCs do tend to "drift" a few minutes over time. They usually take a few months to differ more than 10 minutes from the macs. The server was off by more than 30 minutes.

    Also, all but one of the Virtual Machines were set to synchronize time with the host mac, yet they were able to connect while the host could not.

    Oh, well. All is working. Thank you.
     
  6. erhez macrumors newbie

    erhez

    Joined:
    Jan 7, 2019
    #6
    amazing...

    so much time struggling not to have problems with the shared files .... and the problem is the time of the server differed in 30 minutes ... I put the same of the mac .. and voala
     
  7. hobowankenobi macrumors 6502a

    Joined:
    Aug 27, 2015
    Location:
    on the land line mr. smith.
    #7
    It is odd...but sadly common.

    Even more odd: one would think that Apple AND Microsoft would be aware of the fragility of time sync, and have this be one of the first troubleshooting checklist items.

    I have been told that folks in my org have seen connection issues with less than one minute difference between Mac client and Win server. The solution has been to point both clients and servers at the same time server; that way it does not matter if the time drifts...from the actual time, as they are all in sync. In our case we run our own time server.
     
  8. DJLC macrumors 6502a

    DJLC

    Joined:
    Jul 17, 2005
    Location:
    Mooresville, NC
    #8
    +1, but time sync can be an issue for Windows clients in a domain too. Best practice I was taught is exactly what you said — to have your clients (Mac and Windows both) point at the DC for time, then have the DC point at a public time server.
     

Share This Page