Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors newbie
Original poster
Sep 14, 2012

I'm using osx 10.6.8, and I have MacTubes 3.1.4. I've been able to use MacTubes until earlier this morning.. Since then, when I try to open movies with it, it says "403" in the lower bar and the screen remains black. I've tried uninstalling/reinstalling it, restarting my computer, trying other downloading applications (didn't work - "ImTOO" worked.. but the audio was messed up).

I've searched for possible explanations online, and the only thing that seems to make sense is if YouTube has hindered the ability for these downloading applications to work. If that's the case, how long will it take for the creators to alter the application accordingly? If that's not the case, what can I do to get this working?

Thanks a lot if you know,


macrumors newbie
Mar 14, 2012
I'm also having an issue with v 3.14 on OS 10.8.1. I can play a video, but I can't download it. The error is: Download failed Error - The operation couldn’t be completed. (NSURLErrorDomain error -1102.)...


macrumors newbie
Jan 25, 2013
Similar but tougher fix? Help, please!

I only have OS 10.4.11. I downloaded MacTubes 3.1.6. I am guessing they are not compatible cause while I can get the player to play, the lower left button (icon) I need to use to download a file remains faint and will not do anything if I click on it.

Is there a different version of MacTubes I should be using? Will MacTubes work for me at all? Is there some other suggestion as to what software I can use to download from YouTube onto my mac that is also free (and relatively simplistic)?

Many, many thanks for any/all assistance!
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.