Made a fine mess trying to jailbreak a 3GS, need help!:(

Discussion in 'Jailbreaks and iOS Hacks' started by sk3pt1c, Jan 17, 2011.

  1. sk3pt1c, Jan 17, 2011
    Last edited: Jan 17, 2011

    sk3pt1c macrumors 6502a

    sk3pt1c

    Joined:
    Nov 29, 2005
    Location:
    a simulacrum
    #1
    first of all, i tried to do this on windows, since i was in the uk visiting a friend so was away from my mac, am on it now though.

    being a noob to the whole jaibreaking thingy, i googled and googled and saw that there is a jailbreak for 4.2.1 that updates the baseband as well.

    so i went for it. i noticed cydia wasn't working so i could get the ultrasnow unlock, took some extra steps i saw on some guide (totally do not remember) and i got it to work, installed ultrasnow, it prompted for a reboot, i hit ok and then i got the "plug in to itunes" screen and nothing else...

    i tried to restore to a 4.2.1 version but nothing, i read that's cause the jailbreak updated the baseband or something?

    at this point i just want to restore it to a working iphone (itunes gives me a 1015 error when i try to restore it) and then find a way to downgrade it to 4.1 and jailbreak with pwnagetool.

    please help, you guys (and dolls)!

    thank you!

    EDIT: made a custom ipsw via pwnage tool 4.1.2 to restore it but itunes didn't let me
     
  2. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #2
    I am guessing your 3GS has the new bootrom, and thus, would be tethered JB on 4.2.1. That's why you get the "plug in to itunes" screen everytime the phone reboots. In the future, use Redsnow's tethered boot option to reboot the phone.

    As to not being able to restore normally through itunes, did you install the Ipad 6.15 baseband hack? If yes, from now on, you can only restore using a custom firmware file (one that keeps your current baseband = Ipad 6.15). Use Redsnow to put the phone into a special DFU mode, and then, you should be able to restore with the custom firmware file through itunes.
     
  3. sk3pt1c thread starter macrumors 6502a

    sk3pt1c

    Joined:
    Nov 29, 2005
    Location:
    a simulacrum
    #3
    ok, so trying to jailbreak it again with redsnow gives me an unexpected error

    the phone does have the new bootrom and i installed the ipad baseband on my attempt to jailbreak it

    i tried putting it into pwned dfu mode with redsnow and try to restore from the custom ipsw file that pwnage tool made but itunes contacts apple and responds with an error (1015 i think) and can't complete the restore

    at this point i just want a functioning phone, i don't care if it goes back to stock or jailbroken state

    any ideas?
     
  4. Myzhi macrumors 6502a

    Joined:
    Dec 15, 2009
    #4
    What's is the firmware version of the custom file you are trying to restore with?
     
  5. sk3pt1c, Jan 18, 2011
    Last edited: Jan 19, 2011

    sk3pt1c thread starter macrumors 6502a

    sk3pt1c

    Joined:
    Nov 29, 2005
    Location:
    a simulacrum
    #5
    the phone had 4.2.1 in it so i downloaded the official 4.2.1 file

    put that through pwnage tool and it created the custom iswf file (that itunes rejected, even after putting the phone into dfu mode via redsnow)

    i'd be fine with downgrading it to 4.1 too, i just want it back in a working state

    EDIT: apologies, it was the 4.1 file, as i mention in the following post
    i guess that's why it didn't work, cause the phone has 4.2.1 on it and pwnage tool will only play with 4.1
     
  6. sk3pt1c thread starter macrumors 6502a

    sk3pt1c

    Joined:
    Nov 29, 2005
    Location:
    a simulacrum
    #6
    let me break down what's happening, maybe it'll be easier for someone to help this way

    1. plugging the phone in and asking itunes to restore it with stock software from apple results in a 1601 error (i guess because of the ipad baseband)

    2. having downloaded the stock 4.2.1 ipsw and run it through redsnow 0.9.6b6 (i think it's the b6) to re-jailbreak i get an unexpected error

    3. pwnage tool won't accept the 4.2.1 ipsw, it'll only make a custom ipsw from the stock 4.1 ipsw

    so what are my options here?
     
  7. sk3pt1c, Jan 19, 2011
    Last edited: Jan 19, 2011

    sk3pt1c thread starter macrumors 6502a

    sk3pt1c

    Joined:
    Nov 29, 2005
    Location:
    a simulacrum
    #8
    unfortunately i have the new bootrom 3GS in my hands, so i guess that doesn't apply in my case...

    i got pwnage tool 4.1.3 and downloaded the iPad 3.2.2 firmware that it needs to make a custom ipsw for itunes, gonna try that next and hope for the best, will update right after

    EDIT: yeah, that failed miserably, itunes said the device is not eligible for the requested build (it spat out a 4.1 build after all, i'm guessing that's why)

    looking into it more now...
     
  8. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #9
    If you want to install anything other than 4.2.1, you have to have SHSH blobs. If you don't have the blobs, you have to install 4.2.1. You can't get around it.
     
  9. sk3pt1c thread starter macrumors 6502a

    sk3pt1c

    Joined:
    Nov 29, 2005
    Location:
    a simulacrum
    #10
    i got a custom 4.2.1 build from this dude so i managed to restore the phone

    now itunes says the sim card is not valid so it's jailbreaking time i guess

    but when i use redsnow to do that and just install cydia i get an unexpected error and a white screen

    wtf :(
     
  10. machasm macrumors member

    Joined:
    Dec 21, 2010
    #11
    You need to boot it tethered.
    Use redsnow and select boot tethered option
     
  11. sk3pt1c thread starter macrumors 6502a

    sk3pt1c

    Joined:
    Nov 29, 2005
    Location:
    a simulacrum

Share This Page