Magic Jack with OS 10.3.9

Discussion in 'Mac Basics and Help' started by iaddict, Feb 6, 2009.

  1. iaddict macrumors 6502

    Joined:
    May 15, 2007
    #1
    Has anyone found a work around for using Magic Jack with an older iMac running OS 10.3.9? I bought one and brought it home....tried to use it and then found that they say it only works with Intel Macs. Just hoping that someone has found a way for it to work.
     
  2. madog macrumors 65816

    madog

    Joined:
    Nov 25, 2004
    Location:
    Korova Milkbar
    #2
    Not on topic to help you with your problem, but if you didn't read it, perform a search on google for magic jack and EULA problems. I don't remember it off the top of my head but I believe it had something to do with targeting ads.

    Other than that I've read that the main problem with MJ is that one needs a solid and fast internet connection for it to not cut out or have any problems with its own connection.

    Hopefully you do, but otherwise I thought I'd mention this.
     

Share This Page