Magic Mouse - 2 fingered swipe has stopped working

Discussion in 'Mac Accessories' started by ascender, Nov 14, 2009.

  1. ascender macrumors 68020

    Dec 8, 2005
    I've got an iMac with a Magic Mouse which was working perfectly, but which now refuses to recognise the two-fingered swipe to navigate in any program. I've tried disabling and re-enabling the gesture, rebooted etc.

    Just wondering if anyone has had this problem before?

  2. topmounter macrumors 68020


    Jun 18, 2009
    FEMA Region VIII
    I've been having the same problem, I'm pretty sure it started after the Safari update. It's not working in Safari or Firefox. I thought it might be an issue with the latest version of the BetterTouchTool, however the problem persists even if I close that app. I need to try rebooting and see if that makes any difference.

    edit: After the restart it is working again.

    edit2: Launched BetterTouchTool and everything is working
  3. Macguy805 macrumors newbie

    Nov 18, 2009
    Also have swipe problems

    I got the Magic mouse close to when it came out and it was working fine. I downloaded the new OS update, 10.6.2 and then noticed, that no matter what I did, I couldn't get the swipe to work. Went to level 2 support and they asked me to bring the mouse back to the retail store so Apple Tech support (level 2 people at Apple) could study it. They replaced my mouse at the apple store but a week later, after a sudden power loss on the apple (for no apparent reason), and restarting, I'm encountering the same problem. I guess I'll have to replace this one as well. The scrolling still works but the swipe doesn't. Very strange.

    I hope Apple fixes this soon. I saw some fixes on apples site but sounds like it needs to be done every time I reboot. A bit of too much effort for me to do it everytime. BTW, I'm using a 24 inch iMac 3.06 GHz 4GB , 1 TB HD w/HD4850 ATI Video (last hardware update before the new iMac 27in)

Share This Page