Magic Mouse battery level inaccurately at 0%

Discussion in 'Mac Accessories' started by WillF, Dec 7, 2009.

  1. WillF macrumors newbie

    Joined:
    Dec 5, 2009
    #1
    My magic mouse keeps indicating that the battery level is at 0% even when I just put in some new batteries in it.

    Any insight into this issue? Should I exchange it.

    If I get the unit as part of an imac I got from the apple online store, would I be able to get it serviced at a retail location?

    Thanks.
     
  2. alexk82 macrumors regular

    Joined:
    Nov 30, 2009
    Location:
    East Coast
    #2
    dumb question

    prefacing: dumb question.

    where do you see the battery indicator? is it on the mouse itself. i've never really looked for it
     
  3. Cyclotrode macrumors regular

    Cyclotrode

    Joined:
    Jun 30, 2007
    Location:
    Virginia
    #3
    Go to System Preferences then choose Mouse. The battery indicator is at the lower left hand corner.

    To the OP: Check to make sure that you didn't accidentally insert the batteries the wrong way. If they are inserted correctly, then you should get a Genius Bar appointment set up. Since you got it with your iMac, if they find a defect, they will replace it.
     
  4. rhanbury macrumors newbie

    Joined:
    May 17, 2010
    Location:
    London, UK
    #4
    I have the exact same issue

    Wireless keyboard correctly shows battery level, but magic mouse shows 0% even with new fresh batteries. I'll contact support tomorrow.
     
  5. rhanbury macrumors newbie

    Joined:
    May 17, 2010
    Location:
    London, UK
    #5
    Problem solved with replacement mouse

    Spent hours on the phone with support trying every possible combination of restart and even a complete OS re-install. I then tried it on a friend's Mac and it showed the same symptoms, so they sent me a replacement mouse under warranty and it worked perfectly straight out of the box. So a hardware fault after all!
     

Share This Page