Magic Mouse Lag?

Trey M

macrumors 6502a
Original poster
Jul 25, 2011
943
301
USA
I've recently noticed an issue with Magic Mouse lag with my rMBP. It's very random, not consistent, and it's not the battery/tracking surface/something on the mouse's lens. It seems to be some software issue. 95% of the movement will be perfect but it will randomly slow down significantly...has anyone else experienced this? Is this a ML thing? rMBP specific?

Thanks guys
 

ergdegdeg

Moderator emeritus
Oct 13, 2007
1,628
0
I've noticed it too. It seems to happen constantly when either Hulu or the DVD Player is running, I can't say it happens just randomly, though. It is extremely frustrating.
 

Trey M

macrumors 6502a
Original poster
Jul 25, 2011
943
301
USA
I've noticed it too. It seems to happen constantly when either Hulu or the DVD Player is running, I can't say it happens just randomly, though. It is extremely frustrating.
After looking through some articles, I found that deleting the mouse completely from your Bluetooth preferences and then re-discovering it has fixed the issue for me. At least so far. I've used it for 2-3 hours since and have yet to notice any lag. But in your situation, it's probably lagging a tad since the processor is being taxed by streaming/reading a dvd. But you should try deleting and rediscovering the mouse and see if that fixes the issue for you.
 

Deacon-Blues

macrumors 6502a
Aug 15, 2012
554
591
California
If you are using your MBP in clamshell mode, it could potentially be due to the closed lid interfering with the Bluetooth antenna. I had this problem and was able to resolve it only by using an external micro Bluetooth USB adapter.
 

trillpolo

macrumors newbie
Aug 22, 2012
1
0
My Magic Mouse lags on me also, but it only lags when I'm on YouTube and the videos are buffering. Is that normal or is that a problem? Mostly buffering in 720p HD and up, not below the resolution.
 

Trey M

macrumors 6502a
Original poster
Jul 25, 2011
943
301
USA
My Magic Mouse lags on me also, but it only lags when I'm on YouTube and the videos are buffering. Is that normal or is that a problem? Mostly buffering in 720p HD and up, not below the resolution.
Like I said to the other guy, my guess is that streaming is taxing the processor causing your mouse to lag. I've noticed it a couple of times when streaming, but it wasn't nearly as severe as the lag I was experiencing yesterday. I'd rule a slight lag when streaming video normal, however severe lag might not be so normal. Try deleting the mouse and re-discovering it and see if that helps with video.
 

mgartner0622

macrumors 65816
Jun 6, 2010
1,019
0
Colorado, USA
Try going to your bluetooth preferences, click the gear and select "show more info" then click the gear again and click "add to favorites". This gives the device priority and fixed it for me.