Magic Mouse performance on Mavericks GM

Discussion in 'OS X Mavericks (10.9)' started by CheesePuff, Oct 8, 2013.

  1. CheesePuff macrumors 6502

    Joined:
    Sep 3, 2008
    Location:
    Southwest Florida, USA
    #1
    I just did a clean install of Mavericks GM and have some pretty poor performance with my Magic Mouse. Has a > 80% battery life currently, but the mouse movements can be jittery at times, and the scrolling is definitely not on par with what it was with Mountain Lion.

    Anyone else seeing the same?
     
  2. stisdal macrumors 6502

    stisdal

    Joined:
    Feb 28, 2010
    Location:
    USA
    #2
    Clean install of Mavericks here, and my Magic Mouse acts just fine.
     
  3. jhfenton macrumors 6502a

    jhfenton

    Joined:
    Dec 11, 2012
    Location:
    Norwood, Ohio
    #3
    No problems here with a Magic Mouse and a Mac mini (Late 2012). It sometimes gets jittery when the battery gets under 10%, but that's always been the case. It's at 29% right now and it's working fine.
     
  4. CheesePuff thread starter macrumors 6502

    Joined:
    Sep 3, 2008
    Location:
    Southwest Florida, USA
    #4
    Hmm - after running it now for a few hours I haven't had the jittery issues when moving the mouse around the screen.

    I have a Core i5 2.4 GHz with 8 GB RAM and an SSD, so don't think speed was really an issue, and Spotlight indexing was done for quite a while beforehand. Hmm, hopefully it doesn't continue.
     
  5. jhfenton macrumors 6502a

    jhfenton

    Joined:
    Dec 11, 2012
    Location:
    Norwood, Ohio
    #5
    Any potential Bluetooth interference? New USB 3.0 drives or cables? Moved things around?

    I've never had any issues, but I know some folks have had BT issues with some USB 3.0 hardware.

    Here's hoping it was a transient thing.

    John
     
  6. Cofresi macrumors newbie

    Joined:
    Oct 14, 2013
    #6
    I have the same issues too, looses connection for a few minutes then comes back...
     
  7. afrocleland macrumors member

    Joined:
    Sep 24, 2012
    Location:
    Glasgow
    #7
    Me too! I thought it was the Mac's lack of power (2010 mini), but I really dont think it is!
     
  8. alana22 macrumors regular

    Joined:
    Apr 12, 2007
    Location:
    Seattle
    #8
    Using Mavericks, when I swipe left or right on the top of my magic mouse in Firefox (to go to the page I was just viewing, or back to my most recent page), nothing happens. The only way to get back to the previous page is to click on the back button in Firefox.

    Can anyone else replicate this problem or is it just me?
     
  9. clukas macrumors 6502a

    clukas

    Joined:
    May 3, 2010
    #9
    I did an upgrade and am not experiencing any problems. Scrolling is very smooth across the system.
     
  10. iraklis9 macrumors newbie

    Joined:
    Oct 26, 2013
    #10
    Hi everyone,

    I'm having a problem with magic mouse scrolling. Scrolling seems to stop for a while and it starts again after the third or fourth attempt. Cursor moves ok though. The only problem is the scrolling stopping occasionally for a few seconds. Any ideas? I have a late 2013 iMac and didn't notice any problems in mountain lion.
     

Share This Page