Magic Mouse through window

Discussion in 'Mac Accessories' started by quantum003, Mar 12, 2010.

  1. quantum003 macrumors 6502a

    quantum003

    Joined:
    Apr 27, 2009
    Location:
    Superposition
    #1
    I am about to bounce this Magic Mouse off the wall. When I first got it, it was always on and connected to my Macbook Pro. When I turned on my Macbook Pro my Magic Mouse was at the ready from the very beginning, never had to fiddle with or adjust any settings.

    However my MBP took a dive after a failed Windows install and I had to rebuild it. Ever since the Magic Mouse refuses to work the way it used to. I have to pull a wired mouse out of my desk every single day, log in, and then coerce the stupid magic mouse to finally connect through a process of turning it on and off and trying to connect through bluetooth.

    I'm sick of the whole thing and often times I just used the wired mouse all day because I'm so annoyed by the Magic Mouses's refusal "to just work". My co-workers are all Windows fanboys and they just love to bust my chops about this stupid magic mouse causing me so much frustration, when it used to work exactly the way I wanted and expected it to!

    So please- someone explain to me why the mouse no longer connects automatically when I turn my computer on the way that it used to. I have searched preferences high and low and found nothing. All software updates are complete, batteries are fine.

    Thanks!!
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    This is why I always buy Logitech mice. :D

    If you haven't already, try this:

    Open your Bluetooth Preferences and remove the MM from the device list. Then Set Up a new Bluetooth device and add it again.

    If that doesn't work, just make sure the window is open. You don't want to have to pay for a new mouse AND a new window! :D
     
  3. quantum003 thread starter macrumors 6502a

    quantum003

    Joined:
    Apr 27, 2009
    Location:
    Superposition
    #3
    Thanks for your post GGJ. The little rascal is working for again the way I'd like- I came across this update from Apple Support and ran it-

    http://support.apple.com/kb/DL950

    Problem solved. Wonder why it didn't get passed in through my Software Update automatically though... oh well.
     

Share This Page