Magic mouse will no longer track on a surface it could before.

Discussion in 'Mac Accessories' started by Mustava, Nov 24, 2011.

  1. Mustava macrumors newbie

    Joined:
    Nov 24, 2011
    #1
    Hi everyone,
    So recently and seemingly randomly, my magic mouse has stopped tracking on my desk surface. It moves but jaggedly and only slightly.

    My desk has a semi shiny finish to it, and the magic mouse has always worked on it in the past.

    The weird thing is if i put it on a black surface it tracks fine...

    I have tried the following
    -Cleaning laser lens
    -Resetting pram etc
    -Resetting bluetooth settings
    -Different mac.

    I am confused to what it could be?
    any ideas?
     
  2. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #2
    You say the mouse is not performing with another Mac. This proves the problem is with the mouse.

    Does it work OK on a non-shiny surface?

    Erratic tracking usually results from dirt or a trapped hair in the lenses. Make sure they are really clean. Examine them under a magnifying glass and puff out any dust with a "blower" (used to remove dust etc. from camera lenses) - do not use canned compressed air because it can eject moisture which can cause more harm than good!
     
  3. Ingster macrumors 6502

    Ingster

    Joined:
    Apr 2, 2007
    Location:
    Leeds, UK
    #3
    Sounds daft but have you tried new batteries? Low powered (partly depleted) batteries may struggle with the shiny surface as a stronger beam may be required to track well on that surface where on a darker bsurface it only requires a lower powered beam to track properly.
     
  4. jamesalm macrumors newbie

    Joined:
    Aug 21, 2012
    #4
    Upon upgrading to mountain lion, my mouse was working fine. however my system was not, so I did a full format-reinstall, and THEN my magic mouse stopped tracking on my mousepad, which it had worked on since day one.

    It still worked on my desk though, but I think I may have found a solution.

    It doesn't make a lot of sense, but this is what I did.

    I opened up sys prefs, went to mouse settings, and unchecked 'Smart zoom'
    I left scroll direction off and secondary click on, and miraculously it started tracking on my mousepad again. So maybe just try fooling with the mouse option toggles?

    I dont know or understand why this could work, but it seems to have. give it a shot. And yes, I realize this is an old thread, but it's what comes up on google when you search for this problem. Hope it helps.
     

Share This Page