Magic Mouse & Windows 7 Ultimate

Discussion in 'Windows, Linux & Others on the Mac' started by zzzCookie, Jun 24, 2010.

  1. zzzCookie macrumors newbie

    zzzCookie

    Joined:
    Jun 13, 2010
    Location:
    Singapore
    #1
    I have a Magic Mouse, which worked perfectly on Snow Leopard and Vista Ultimate. Then, I updated to Windows 7 Ultimate and it appears that the system keeps trying to connect to the Magic Mouse. By the way, it still works on Snow Leopard, so the problem is isolated to Windows 7. Can anyone help? Thanks in advance.
     
  2. DonCarlos macrumors regular

    DonCarlos

    Joined:
    Dec 14, 2009
    Location:
    Las Vegas
    #2
    I did find a solution that worked for me (perhaps it will help someone else). This also works whether it is a Magic or Mighty mouse and whether it's for W7 or XP. Not sure if Ultimate Edition will make a difference. You can give it a try.

    Follow this step by step, while you are in Windows.

    1) Switch off the device you want to pair
    2) Select "add a device" in the Bluetooth menu
    3) Switch on the device (after few second it should get detected by windows)
    4) Now, right click on the device and select properties. You should now get a window with the different services.
    5) select the HID drivers for keyboard and mice and click OK (this is the important part)
    6a) In windows 7 it should setup mouse and keyboard without any additional input.

    I found that cure posted by S_ Eye at http://discussions.apple.com/thread....art=0&tstart=0
     

Share This Page