Magic TrackPad 2 haptic feedback not working.

Discussion in 'Mac Accessories' started by Fetseun, Jul 23, 2019.

  1. Fetseun macrumors newbie

    Fetseun

    Joined:
    Oct 16, 2017
    Location:
    Perth Australia
    #1
    Hi Guys,

    I have had issues with my Magic Trackpad 2 for sometime now and can't find a solution.

    Every so it will work for a few seconds and then back to no feedback.

    Any suggestions? needless to say its just fallen outside of warranty....
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #2
    Make sure the cable is not pinched anymore. Plus do a zap your PRAM by these instructions.
     
  3. Fetseun thread starter macrumors newbie

    Fetseun

    Joined:
    Oct 16, 2017
    Location:
    Perth Australia
    #3
    Thanks, the mouse uses bluetooth not a cable.

    I will give the PRAM a try, but it does it on all my macs, which makes me think its the trackpad not the configuration?
     
  4. Alicia1 macrumors regular

    Joined:
    Nov 13, 2009
    Location:
    Gold Coast, Australia
    #4
    I had the same issue with my magic trackpad 2 approx a year ago. Nothing I tried got it working again, took it into apple, they tested it and and then replaced it.
     
  5. Fetseun thread starter macrumors newbie

    Fetseun

    Joined:
    Oct 16, 2017
    Location:
    Perth Australia
    #5
    Thanks, I am outside the warranty period. I am not sure they will be so accomodating :)
     
  6. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
    #6
    PRAM reset a chip that controls the ports on a Mac!
     

Share This Page

5 July 23, 2019