Magic Trackpad cursor not moving

Discussion in 'Mac Accessories' started by thewolfro, Aug 3, 2010.

  1. thewolfro macrumors member

    Joined:
    Aug 27, 2009
    #1
    Dear All,

    I have read few treads that deal with similar issue, i follow all the instructions and more from the other boards and i still did not manage to make my trackpad working with my iMac which i bought last year in May.
    First of all except the other users that wrote on other discussions i never had USBOverdrive installed on my Mac or any other software used for peripheral devices.

    Here is what i did:

    a) as soon as i took the Trackpad form the box i power it on. My mac did not see anything at this point.

    b) i wen to the Bluetooth settings and asked it to search for devices, very fast it found my Trackpad and installed it. As soon as this was done a nice icon showed up in System preferences then i did the system update (it fond trackpad update) and i hoped i nailed it down but Noooo!!! the cursor was not moving. I rebooted 2 times but still nothing.

    c) i tried to take the batteries out put them back turn of and on.. Nothing the only thing that my trackpad is able to do correctly is to click

    d) Ok i said... time to read more on forums..did some research and i seen people talking about USB-Overdrive. at first i did not know where to look for that to see if it is there or not and in the end i figured out it is a 3-rd party software.

    e) i have installed it just to remove it afterwards (hoping that maybe this will correct the issue). off course i did the reboot after the install and after uninstall (as the system requested) but my trackpad remains dead (just the clicking most wanted capability in place).

    f)i tried to remove my trackpad form bluetooth "-" and reboot my Mac. After it came up i turned on/off/on my trackpad few times but still the device was not recognized. Since now i had the nice Trackpad icon under System i clicked on that and my trackpad was recognised but again i cannot move the cursor. Stupid Device...

    g)i tried to install the combo for 10.6.4 (i already had 10.6.4) but i was thinking that i probably have an issue that the combo will fix. but again i was not correct because after the instalation and after i followed a,b,c,d,f again the trackpad is still not tracking anything.

    h)i tried to look into the logs (kernel and system) and here is what i see when i add my trackpad (after kicking the trackpad icon)

    ====
    Kernel
    ====
    Aug 3 21:45:27 xxxx kernel[0]: 0a69d000BNBTrackpadDevice::init54 init is complete
    Aug 3 21:45:27 xxxx kernel[0]: 0a69d000BNBTrackpadDevice::probe54 entered
    Aug 3 21:45:27 xxxx kernel[0]: 0a69d000BNBTrackpadDevice::handleStart54 Done
    Aug 3 21:45:27 xxxx kernel[0]: 0a67e400AppleMultitouchHIDEventDriver::start entered
    Aug 3 21:45:27 xxxx kernel[0]: 0a76a780AppleMultitouchDevice::start entered

    ======
    System
    =====
    Aug 3 21:45:26: --- last message repeated 1 time ---
    Aug 3 21:45:26 xxxx blued17: addDeviceToHIDEmulationMode - unrecognized HID device; NOT storing the link keys to the module.
    Aug 3 21:45:26 xxxx blued17: isCSR: 0 isBRCM: 0
    Aug 3 21:45:26 xxxx blued17: major class: 5 minor class: 37

    From the system.log it seem that the HID is not recognized...

    I kind of run out of any ideas here and i would really appreciate some help.

    Thanks,
    George
     
  2. thewolfro thread starter macrumors member

    Joined:
    Aug 27, 2009
    #2
    I have done some more search and i have tried to install BetterTouchTool with this the cursor of my Trackpad is moving but it is so jumpy that you cannot use it at all :(
     

Share This Page