Magic Trackpad loses connection after sleep and doesn't connect again.

Discussion in 'Mac Accessories' started by InsanelyApple, Jan 17, 2011.

  1. InsanelyApple macrumors 6502

    InsanelyApple

    Joined:
    Oct 26, 2010
    #1
    Well as the title says my Magic Trackpad will be connected and working fine until I turn the Mac to sleep mode. When it wakes up it won't connect again to the Mac until I restart the Mac. Why does this happen, and what can I do about this?
     
  2. InsanelyApple thread starter macrumors 6502

    InsanelyApple

    Joined:
    Oct 26, 2010
  3. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #3
    I suddenly had this same issue and all I did was change the batteries and it stopped. I realize that's stupid, but it worked for me.
     
  4. InsanelyApple thread starter macrumors 6502

    InsanelyApple

    Joined:
    Oct 26, 2010
  5. obdave macrumors member

    Joined:
    May 25, 2008
    #5
    drives me nuts

    I have been having the same issue. Both my keyboard and magic trackpad will have "connection lost" issues. It always happens after waking up from sleep, and on rare occasions it'll happen while I'm using my iMac. It sometimes takes 10-20 seconds for them to reconnect. I was not having this problem until several weeks ago. Also - and this might be related - bluetooth events also started waking my Mac up, and I had to disable the ability for Bluetooth to wake the Mac. Now the Mac sleeps through the night. But I still have "connection lost" issues when the Mac wakes up.

    Things I have tried so far:

    * changing the batteries.

    * making the keyboard and trackpad bluetooth "favorites" in the pref pane

    * deleting the three bluetooth .plist files

    the last two were suggestions from other threads. I don't know what else to try. I can't help but think this is some sort of a software issue because they were working fine for months.
     
  6. sstringer macrumors newbie

    Joined:
    Apr 15, 2009
    #6
    I was having the exact same problem and was one day away from returning my less-than-magic trackpad. After researching, the solution turned out to be smack-myself-in-head simple. According to Apple:

    So, yeah. Click the damn thing instead of trying to move the cursor around. Worked like a charm for me.
     
  7. obdave macrumors member

    Joined:
    May 25, 2008
    #7
    Wow, I'd forgotten about this thread but I just got this notification. My issue is resolved too, but for different reasons. My iMac appeared to be waken up by the USB hard drive that Time Machine uses. For reasons I don't really understand, turning off the "wake via Bluetooth" option solved that issue. It makes no sense, but the Mac no longer woke up spontaneously. So to wake the Mac up, I now had to reach around the back to push the power switch, and when the Mac woke up, the trackpad would be off in la-la land for awhile.

    A couple months ago I finally got around to buying a larger HD, connecting it to the Airport Extreme, and migrating the time machine archive to this new drive. So I no longer have a USB drive connected directly to the iMac. I was able to turn "wake via Bluetooth" back on, and the Mac no longer wakes up spontaneously. And now I can wake the Mac by clicking on the trackpad, and the trackpad is immediately active. Problem solved.

    Very odd, but there it is.
     
  8. Greg Tucker macrumors newbie

    Joined:
    Dec 22, 2004
    #8
    Magic Trackpad doesn't connect? It does now!

    The product's online manual says...

    "The indicator light displays the status of your Apple Magic Trackpad and the batteries. When you first turn on your trackpad, the indicator light glows steadily for 2 to 3 seconds, indicating the batteries are good."

    I observed that my green light revealed itself for just ONE second, not 2-3. Changed them, and — voila! — success.
     
  9. jterp7 macrumors 6502a

    Joined:
    Oct 26, 2011
    #9
    yeah its usually the batteries. That said I usually use the BT keyboard to wake from sleep and have never had any problems there.
     
  10. ODivaEx macrumors newbie

    Joined:
    Jul 10, 2011
    #10
    Apple Trackpad & Mouse Connection Lost Issue

    Just back from the Apple Genius Bar with advice on the issue of my trackpad and mouse losing connection frequently despite changing to new batteries.
    => Advised not to use Duracell nor Eveready Batteries only Energizer or Rechargeables only. The former 2 brands cannot supply a constant very high demand of power to both devices. I went ahead and purchased the Apple Battery Charger for AUD$30 which comes with 6 x AA Batteries and now both are working perfectly - No More Lost Connections!!!:D apple:
     
  11. TheAppleMacMan macrumors newbie

    Joined:
    Sep 8, 2015
    #11
    Aware that this is quite an old post now but was being driven nuts by the delay I was getting after sleep wake-up before the Magic Trackpad was usable.... could easily be a good 30 secs. Tried most / all of the hints and tips I could find to very little effect.

    However........ just tried moving the BTth icon on the Menu bar ( CMD ALT Drag) from its normal position (about 7th in ) to 2nd in (as counted from the Right), i.e. next to the Spotlight menu.......

    So far?......... problem gone, trackpad alive and kicking within a few seconds!

    Not 100% sure why this would be, but suspect it might be something to do with the order in which tasks from those items on the RHS Menu Bar are addressed after wake-up...... i.e. those nearer RHS have higher priority?

    Only takes a couple of secs to do, so if you also have this problem - might be worth a try?

    ( iMac 27" i7 / OSX 10.10.5)

    JH
     
  12. mac-n-tosh macrumors newbie

    mac-n-tosh

    Joined:
    May 18, 2017
    #12
    That helped a lot, not using duracell or eveready also makes a difference, sometimes the problem can be a combination of both.

    Your solution also fixed up the issue I had with my bluetooth speaker not automatically being picked up by my mini as well, now it gets picked up straight away.
     

Share This Page