Magic Trackpad multi-touch gestures don't work on left side

Discussion in 'iMac' started by ElCani, Nov 8, 2016.

  1. ElCani macrumors member

    Joined:
    Jun 15, 2012
    #1
    Hi - I have an odd problem with my Magic Trackpad (paired with 27 2011 iMac running Sierra public beta). Multi-touch gestures such as four-finger Mission Control and three-finger drag don't work if my hand/fingers are over to the left side of the trackpad surface. If the left-most finger is roughly on the left-most 20% of the trackpad, it doesn't seem to register and the gesture doesn't work. So, for example, attempting the four-finger Mission Control gesture results instead in a three finger drag. One-finger moving of the cursor works normally across the entire trackpad.

    Has anyone experienced this or something similar? Any ideas whether it's hardware or software related? I can't be sure when it started, but it's been through at least a couple of Sierra PB releases, possibly more. Disconnecting and reconnecting the trackpad has no effect.

    Thanks.
     
  2. ElCani thread starter macrumors member

    Joined:
    Jun 15, 2012
    #2
    Nobody come across this before? Can't imagine it's related to the bug in the new MBPs, but maybe...
     
  3. IngerMan macrumors 6502a

    IngerMan

    Joined:
    Feb 21, 2011
    Location:
    Michigan
    #3
    just did 4 finger mission control with my left most finger on the left edge and it works for me. Tried a few times no problem.
     
  4. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #4
    How long have you owned your Magic Trackpad?
    Have you noticed that before, or has it only been since you upgraded to Sierra?

    Take your trackpad to an Apple store. Try it out on another Mac.
    If you see the same problem on a different Mac, then perhaps you just need to replace that trackpad, as the sensor surface has partially failed (probably).
    If it is less than 12 months old, then you might get a warranty replacement, unless your original purchase is part of a purchase of another Mac that might have AppleCare. That would probably be the only way you would get your present trackpad replaced, without needing to purchase a new one.
    Or, it works properly on another Mac, and you have a software issue of some kind.
    Be sure to try out your trackpad while logged in to another user account on your own Mac. That would be a good test, and a good reason to create a new user just for the trackpad test.
     
  5. ElCani thread starter macrumors member

    Joined:
    Jun 15, 2012
    #5
    Cheers for the replies. Have now tried with a different trackpad and everything works fine.

    Further investigation has revealed that the dead patch is actually a vertical strip (roughly a centimetre wide) that starts about a centimetre in from the left of the trackpad. No touches (multi or single) are registered in this area. The left edge is in fact ok. I've tried re-pairing, using a different user account etc, with no luck, so it would appear to a hardware issue.

    Time for a new one!
     

Share This Page