Magic Trackpad on iMac: can't see it in SystemPrefs

Discussion in 'Mac Accessories' started by wahoo10, Aug 16, 2010.

  1. wahoo10 macrumors 6502

    Joined:
    Feb 11, 2009
    #1
    Hi all
    My dad has a Jan '10 iMac (27" i7) with SL and all updates on it. I got him a MTpad for his bday recently and we've been having some troubles.

    We can connect it via bluetooth and it works (responds to gestures/"clicks") but it doesn't show up in SystemPrefs after it's connected. When we go via the Bluetooth>Apple Magic Trackpad>Open Mouse Preferences, it takes us to the Mouse section in SystemPrefs.

    Tried restarting after connecting, tried disconnecting, restarting, re-connecting, restarting again...no avail. Any suggestions? Thanks :eek:
     
  2. 007bond macrumors 6502a

    007bond

    Joined:
    Dec 12, 2008
    Location:
    DFW, Texas
  3. wahoo10 thread starter macrumors 6502

    Joined:
    Feb 11, 2009
    #3
    ya know, I kept asking him if he did all of his updates!! Saw the update in my own updates, went in to double check, and sure enough....ugh *facepalm*

    Needless to say, he loves it :rolleyes:
     
  4. jmck macrumors newbie

    Joined:
    Jul 18, 2002
    #4
    same thing here

    I just got a Magic Trackpad to use with my 2007 Mac Mini, and am experiencing the same half-hearted response, it's acting like a generic pointing device. I'm running lion 10.7.2.... so shouldn't require the software update mentioned above.... I tried it on my 27" iMac and my Macbook Pro at work and experienced even less satisfaction.... any ideaS?
     
  5. drambuie macrumors 6502a

    Joined:
    Feb 16, 2010
    #5
    The update probably isn't included in the Lion upgrade. It's to support a specific peripheral, namely the Magic Trackpad, and separate from the OS. It wouldn't hurt to try installing the update, which is probably more akin to a driver that's installed as needed.
     

Share This Page