Magic Trackpad won't pair

Discussion in 'OS X Yosemite (10.10)' started by Cave Man, Jan 27, 2015.

  1. Cave Man macrumors 604

    Cave Man

    #1
    I have a Mac Pro 5,1. My Magic Mouse has been fine since installation of Yosemite, but my Magic Trackpad won't pair. In the System Preferences Trackpad pane the trackpad shows up but when I try to pair I get the message "The pairing attempt was unsuccessful. Click Continue to try again." But it just goes through the process all over again. And again. And again...

    Rebooted. Shut everything off. Even tried manually restarting bluetooth in Terminal:

    sudo kextunload -b com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport
    sudo kextload -b com.apple.iokit.BroadcomBluetoothHostControllerUSBTransport


    Fresh alkaline batteries, trackpad is about 1 foot from the Mac Pro. Any ideas? Trackpad pairs fine with my MacBook Air. I just can't get it to pair with the Mac Pro.
     
  2. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #2
    Try "unpairing" it from the Macbook Air and then try to pair it with your MacPro.

    I've found this to work for me in the past.

    This Link refers to the unpairing trick.
     
  3. iPhil macrumors 68040

    iPhil

    #3
    If the trackpad is "paired" with MBP then you need to unlink the pair and re pair it withe MP.. Keyboards / Mice / Trackpads can't be be "paired" with 2 different Macs ... Strange..
     
  4. hallux macrumors 68020

    hallux

    Joined:
    Apr 25, 2012
    #4
    I ran into this on my MBP after the Yosemite update on both that and my Mini. Even after disconnecting the MTP from the Mini I couldn't get it to link up to the MBP, even if I put the MTP into pairing mode.

    I tried it again a few days ago (after MONTHS of not using it with the MBP) and it suddenly connected and worked. No idea what changed to resolve it.
     
  5. Cave Man thread starter macrumors 604

    Cave Man

    #5
    Thanks much. Unpairing was the solution. It seems a smarter dialog for dumber people should have popped up! :)
     
  6. jbarley macrumors 68030

    jbarley

    Joined:
    Jul 1, 2006
    Location:
    Vancouver Island
    #6
    Glad I could help. :)
     
  7. swjbud macrumors newbie

    swjbud

    Joined:
    Mar 10, 2016
    #7
    I had a problem where my Magic Trackpad 2 wasn't showing up on my Macbook after returning to work after the weekend. It wouldn't show up in the pairing screen but did show up on other Macbooks. I reset the computer and the PRAM but still wouldn't show on my machine.

    I fixed it by holding SHIFT + OPTION and clicking on the bluetooth icon in the menu bar. Then Debug > reset Bluetooth Module and it worked perfectly.
     
  8. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012

Share This Page