Magsafe 60w Power Adaptor not charging

Discussion in 'MacBook' started by sean83, Jul 29, 2012.

  1. sean83 macrumors newbie

    Joined:
    Feb 14, 2008
    Location:
    Australia
    #1
    Just received my new Magsafe 60w Power Adaptor from the apple store today, however although it is powering my MacBook, it is not charging it.

    I bought my MacBook in early 2008 and it is version 10.5.8, so I looked for solutions and followed this guide on the apple support site http://support.apple.com/kb/TS3499.

    I dowloaded the update http://support.apple.com/kb/DL1312 accordingly but when I try to install it, it says " Alert: This computer does not need this update"

    So I am pretty much lost with what to do, has anyone else had this problem and managed to resolve it?


    Thanks Anyone :)
     
  2. Drew017 macrumors 65816

    Drew017

    Joined:
    May 29, 2011
    Location:
    East coast, USA
    #2
    I bought my MacBook in early 2008 and it is version 10.5.8, so I looked for solutions and followed this guide on the apple support site http://support.apple.com/kb/TS3499.It's possibly something may be wrong with the MacBook's battery. Did you try to remove it for a while then put it back in?

    Odd... your macbook should be supported in this update...
     
  3. sean83, Jul 29, 2012
    Last edited: Jul 30, 2012

    sean83 thread starter macrumors newbie

    Joined:
    Feb 14, 2008
    Location:
    Australia
    #3
    Yeh, I've removed the battery, held the power button down for 5 secs, I've checked that my Mac intel dual core is using the GUID disk partition, which it is.

    I don't get why it won't install.
     
  4. Drew017 macrumors 65816

    Drew017

    Joined:
    May 29, 2011
    Location:
    East coast, USA
    #4
    If there's an Apple store close by, take your MacBook and adapter to the Genius Bar and see if they can help.
     

Share This Page