MagSafe Adapter

Discussion in 'MacBook Pro' started by LethalUK, Jul 25, 2010.

  1. LethalUK macrumors member

    Joined:
    May 2, 2009
    #1
    Hello,

    I have had my MBP since August, but today my MagSafe Adapter is acting strangely.

    Every so often, the green LED will fade away. Sometimes for a couple of seconds, sometimes for up to a minute.

    Does this mean that it is about to give up the ghost?

    Thanks.
     
  2. CaptainChunk macrumors 68020

    CaptainChunk

    Joined:
    Apr 16, 2008
    Location:
    Phoenix, AZ
    #2
    My MagSafe adapter has been exhibiting the same behavior for several months (Early 2008 MBP), but everything still works fine. It still provides power to the machine and charges properly.
     
  3. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #3
    When the light goes out, does it still show the computer as being plugged into a power source?
     
  4. TheBritishBloke macrumors 68030

    TheBritishBloke

    Joined:
    Jul 21, 2009
    Location:
    United Kingdom
    #4
    Mine did that. Call apple. They will replace the transformer for free.
     
  5. ouimetnick macrumors 68020

    ouimetnick

    Joined:
    Aug 28, 2008
    Location:
    Beverly, Massachusetts
    #5
    Same issue here. The green led fades, and is extremely dim. It only happens randomly, and comes back on. The computer keeps charging though.
     
  6. DanMacApple macrumors 6502

    Joined:
    Jul 1, 2010
    #6
    Try to get it replaced by Apple as it seems to be defective!
     
  7. LethalUK thread starter macrumors member

    Joined:
    May 2, 2009
    #7
    Ok, thanks for your help. It still charges when it happens, but I'm going to talk to Apple as I don't really want to have to wait to get one shipped to me or to pick one up if it does indeed break.
    :)
     
  8. ryannazaretian macrumors 6502a

    ryannazaretian

    Joined:
    Sep 21, 2008
    Location:
    Mississippi
    #8
    Clean the contacts. Every time that happens to me, I just have to rub the connector with a pencil eraser. It works fine for months after that then.

    I doubt anything is actually broken. Try this first. If that doesn't work, call Apple.
     
  9. djasterix macrumors 6502a

    djasterix

    Joined:
    Apr 10, 2010
    Location:
    Paradise City
    #9
    Same happened with the adapter on my 13" late 2007 MacBook, Apple replaced it for free.
     
  10. unamused macrumors 6502

    Joined:
    Oct 25, 2009
  11. DustyLBottoms macrumors regular

    Joined:
    Sep 8, 2009
    #11
    Haven't you heard? Old MagSafe LEDs don't die, they just fade away.....



    ;)
     
  12. jclardy macrumors 68040

    jclardy

    Joined:
    Oct 6, 2008
    #12
    My old style Macbook mag safe started doing the led turnoff thing. After a while it started to get hotter at the end that hooks up to the Macbook. At some points I found that the cable actually became less stiff because the plastic was heating up so much. Eventually it would stop charging. I took it into the genius bar and it would not stop charging, but it got really hot and the green led turned a brighter yellowish color.

    So I got it replaced for free. But that was probably a different issue as it was with the old style.
     

Share This Page