Magsafe battery/Terminal lockout

Discussion in 'Mac Apps and Mac App Store' started by AkionTotocha, Feb 11, 2012.

  1. AkionTotocha macrumors newbie

    Joined:
    Feb 11, 2012
    #1
    Hello to you all~

    The problems I have sound unrelated, but actually are.

    Quite recently I started having problems with my battery in my MacBook. It's a white one, and was purchased in the UK in february 2007. I believe it is 13", as it's not as big as my dad's, his is 15", and is bigger than the 11" air's that I've been handling seem to have smaller screens. I'm running OSX 10.6.8, have 2GHz Intel Core 2 Duo processor, and have 2GB 667 MHz DDR2 SDRAM memory. (These numbers are provided by "about this mac" tab)

    Last week I was using my macbook, and everything was running as normal. I closed the lid of my mac. When I went back, I opened my mac, only to find that the magsafe wouldn't light up, also it wasn't charging the battery.(I don't believe it was, it might have been, but at the time I didn't check the lights underneath. The actual mac acted as though I hadn't plugged the magsafe in.) Everything was turned on, my house power lines are fine etc. My magsafe works absolutely fine on my dad's macbook. After I re-started the mac, the computer started acting normally again.

    But a few days later the problem returned. Restarting worked once, then a few hours later the same thing happened, and restarting did nothing. I unplugged the magsafe at the wall and plugged it back in, and it worked again. The next day it wouldn't work at all, so I started using my dads magsafe, and that worked, until my mac randomly decided it didn't want to accept it. (I've been trying different power outlets in my house, both upstairs and downstairs, nothing makes any difference) I started looking for help online.

    One person who seemed to have a similar issue said that they had rapidly removed and inserted the magsafe a few times, and that caused the magsafe to act like it was behaving. It went green for a few seconds, before changing to orange. But the icon on the top bar said that the mac was still running from battery. After a minuet of saying this, it changed (without me touching it) to say it was charging the battery, but running from the power adapter, which is what it usually says. I unplugged the magsafe, but the software said it was still running from Power Adapter, for about a minuet, until it changed to battery. I popped the magsafe in again, the software still said battery, but the lights on the actual battery were charging.

    Reading on from the first poster, someone else said they had the same problem, and that the people at the apple store had said the problem was a corrupted sleep image. (the actual thread is here: http://forums.macrumors.com/showthread.php?t=1291860 ) I went to delete the sleep image, and this is where the Terminal lockdown comes in.

    I forgot to change accounts to admin, and when prompted for my password, I entered my day-to-day user account password. Terminal told me that this was not the correct password, and that it would send a report out. Then a pop-up appeared "Do you want the application "Master" to accept incoming network connection?" This scared me, so I went to google exactly what master was, but whilst searching, the pop-up window closed itself.

    I then logged onto the admin account to try again, but when I tried to enter my admin password, it wouldn't register it - as if I wasn't pressing the keys (I could cancel the command with "ctrl+c", then enter other letters, it was just the password bay it would't accept for). I restarted the mac but it did the same thing. On all user accounts, it won't accept the password.

    I guess what I'm saying is: I've gaffed up majorly with Terminal. I don't use it too much, and I'm trying to avoid a wipe+OSX install. If anyone has any help or advice it would be greatly appreciated, but I understand if there's not; that was the only article that I could find, although maybe that's because I'm not very good googling. It just doesn't seem like a common issue.

    And I'm sorry if I've rambled or if this post is too long, I've tried to include everything, although I'm probably missing a lot of stuff, and if you ask for information then I'll happily provide it, as long as I know how to get it (I'm not overly great with computers, it's the reason I was sold on mac's in the first place.)

    -oh, I almost forgot: I've done a check and repair on disk utilities. It's something like "<something> permissions" and "repair permissions" That didn't solve it, but I did that before I did the rapid unplug/plug thing, so maybe it was that that solved it, or maybe it was the unplugging. I don't know.

    Thank you for taking the time to read this, I genuinely do appreciate it. :)
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
  3. AkionTotocha thread starter macrumors newbie

    Joined:
    Feb 11, 2012
    #3
    Ah, thank you for the link, but unfortunately it hasn't I'm afraid :(

    It made me remember something I forgot: I did reset the SMC. And having checked the battery performance, the status is "normal"

    Also, I don't think it is the battery. I get about 3-5 hours from a full charge, but it's the original battery, about five years old, and has had no proper battery care throughout it's life. I barely ever wind it down to empty, and mostly use the mac with the magsafe plugged in, so I'm pretty happy with the time I get from it, considering.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    So what question do you have remaining unanswered?
     
  5. AkionTotocha thread starter macrumors newbie

    Joined:
    Feb 11, 2012
    #5
    To do with the software: is there any way to stop my mac acting funky when I plug the magsafe in, without using Terminal, or how to fix Terminal so I can use it to stop my mac going funky, or if I'll have to install OSX again. :)
     
  6. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #6
    You never have to touch Terminal to deal with anything related to the MagSafe adapter or battery or charging. Leave Terminal alone unless you absolutely know what you're doing. It's a great way to screw up your Mac.

    Check out the link for troubleshooting MagSafe adapters at the bottom of the CHARGING section of the following link.

    What specific problems are you having when you plug in the MagSafe? "Mac acting funky" isn't very helpful.
     
  7. Darth.Titan macrumors 68030

    Darth.Titan

    Joined:
    Oct 31, 2007
    Location:
    Austin, TX
    #7
    For this part, Terminal doesn't show any characters when typing a password. It's not like in the GUI where your password is masked with bullets, in Terminal there is no output whatsoever in a password prompt. It is however registering your keystrokes. Just press enter after typing your password. This is normal, and completely unrelated to your battery issues.
     
  8. AkionTotocha, Feb 11, 2012
    Last edited: Feb 11, 2012

    AkionTotocha thread starter macrumors newbie

    Joined:
    Feb 11, 2012
    #8
    Sometimes the light doesn't light up, then other times it does but the computer doesn't acknowledge it (but the battery is still charging because I can see the lights on the bottom of the battery), then other times it does acknowledge it - but only after a minuet of waiting (the light still lights up though) And when I unplug the magsafe, the computer acts like it's still plugged in for about a minuet, until it realizes. (The battery realizes though, and stops acting like it's charging) Occasionally I'll be using the mac whilst it's charging, and the screen looses it's brightness like I've pulled the magsafe out. The light on the magsafe goes out like it's been unplugged, but it's not when the battery is 100% or anything, it's random.

    I was using Terminal to delete the sleep image, as it sounded corrupt. When I close the lid to my macbook, I start getting problems. If I leave the lid open and it goes to sleep due to inactivity, the magsafe is still fine when I wake it up. But if I open the lid I start getting the problems.

    I've used 2 different magsafes, and both work on my dad's macbook, but not on mine. It feels software related.

    edit: I did look at that "troubleshooting magsafe" link before I made an account here, but none of the solutions solved anything, and it happens to both adapters.

    ----------

    That's good to hear, thank you :)
     
  9. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #9
    The sleepimage has nothing at all to do with MagSafe or charging issues. Deleting it will not help. If you've verified the MagSafe adapter is working fine by following all the troubleshooting steps, and if you've properly reset the SMC, then you should take your Mac to the Apple store to let them look at it, as it could likely be a problem with your logic board.
     
  10. AkionTotocha thread starter macrumors newbie

    Joined:
    Feb 11, 2012
    #10
    I did do it, and it seems to be working now, but it's probably coincidental. It's lucky I'm going there soon, but I really hope it's a cheeper problem, because if it's as expensive as I've seen quotes for it's probably going to be the end of the line for my first Apple product :(

    Anyway, thank you for your assistance, and Darth.Titan's too. It means a lot that you took the time to help me out :)
     

Share This Page