Magsafe charger green light didn't turn on (Help)

shakra00

macrumors member
Original poster
Sep 7, 2010
94
0
Guys have you encountered a time when you plugged in the magsafe charger then there was no green light, and you had to remove and reconnect it?

My OCD is kicking in.

BTW, Im using my mid 2014 MBP.
 

DJJAZZYJET

macrumors 6502
Jun 4, 2011
411
7
This has happened to me as well. 2014 rMBP (got it two days after they came out). Nothing seems to be wrong with it, but the first time I plugged the machine in the magsafe light didn't come on. It has happened once or twice since then. Apple will probably fix it in an SMC update. Just report the issue to apple via their feedback site.
 

Lachhh

macrumors regular
Aug 30, 2014
207
11
Mainland Europe
2014 15" MBP and same thing here.
An SMC reset seems to have fixed the issue for me, though the glitch may well come back and be a sign of a more general flaw in the subsystem that Apple need to look into.

I haven't worried about it a scrap.
 

EOB

macrumors regular
Sep 6, 2014
137
11
Los Angeles
lol yes, except in my case the charger went bad. It stopped turning on and took it to apple, since my macbook was only 3 weeks old. They just replaced my charger since it went bad...

It has been 2 weeks with my new charger and have not had any problems with it. But these magsafe chargers are ****. I also have a Mid-2014 rMBP 15
 

shakra00

macrumors member
Original poster
Sep 7, 2010
94
0
Is this adaptor related? It seems that it still charges even if there is no light.
 

EOB

macrumors regular
Sep 6, 2014
137
11
Los Angeles
My adapter would not have any light on when connected and was not charging my macbook.

Seems this is a common problem with the chargers included in mid-2014...
 

Nr123*123

macrumors 6502
Jul 1, 2014
296
1,014
Can you guys run a diagnostic test to see if you get a battery error message?

Haven't had the MagSafe not working on my Mid-2014 15", but I get a PPP003 saying the battery may not be charging properly.
 

bushido

Suspended
Mar 26, 2008
8,070
2,754
Germany
occasionally happens on my late 2012 rMBP too but the same happened on my old macbook pro after a while. as long as it is still charging however and theres no issue with the connector on the macbook side i am okay with it
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.