Magsafe Connector Problem

Discussion in 'MacBook Pro' started by surfnode, Oct 9, 2013.

  1. surfnode macrumors member

    surfnode

    Joined:
    Aug 27, 2013
    Location:
    United Kingdom
    #1
    Hi,

    I am having a problem with my 2008 2.5ghz Macbook Pro (A1260) where the laptop is not always charging when plugging in the Magsafe adapter - the light does not go orange/green.

    If you give it a wiggle, the light then laminates and the laptop says its charing.

    Any ideas to help clean / resolve would be helpful.

    Thanks
     
  2. durkkin macrumors regular

    Joined:
    Sep 23, 2013
    #2
    Three possibilities:

    1. There is an issue with the charger. New one is $85

    2. There is an issue with the magsafe board on the computer. Apple Store can replace it or you can do it yourself. Part is about $8.

    3. Your logic board is having issues, in which case you have to replace the whole board. That repair is more in the $350+ range.
     
  3. laurihoefs macrumors 6502a

    laurihoefs

    Joined:
    Mar 1, 2013
    #3
    Before you go and purchase anything expensive:[​IMG]

    Cotton swabs, to the rescue! Try cleaning the contacts on the connectors with one of these. Use them dry, or add a cleaning solution, like LCD cleanser.

    If that does not make any difference, go through durkkins excellent list.
     
  4. durkkin macrumors regular

    Joined:
    Sep 23, 2013
    #4
    Good call. Sometimes the simple solutions are the best.
     

Share This Page