Magsafe Dead!!!

Discussion in 'MacBook Pro' started by rhcp128, Jul 20, 2007.

  1. rhcp128 macrumors newbie

    Joined:
    Jun 20, 2007
    #1
    Hi!

    I have a problem with my magsafe. It was working like a charm until today. I was working on my mbp and then I hear a loud pop from the power brick and now it's not working anymore. When I shake it something inside is broken... I haven't dropped it or anything so i have no idea what the problem is. It wasn't a power surge... Everything else in my home works perfectly and the circuit breakers are ok.... Do you think Apple will replace it? Any body have any experience with the issue?
     
  2. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #2
    They should replace it without problems. Don't play around with it anymore... it may be a fire hazard at this point and/or could produce a surge that would damage your Macbook. Just take it in and talk to the Genius bar. It shouldn't be a issue.
     
  3. Hipnomac macrumors regular

    Hipnomac

    Joined:
    Jun 14, 2007
    Location:
    Chicago
    #3

    THis happened to me two days ago. My power adapter got extremely hot, I moved rooms, and went to plug it in and it wouldn't turn on again.

    I went to the apple store and they replaced it with no problem.
     
  4. rhcp128 thread starter macrumors newbie

    Joined:
    Jun 20, 2007
    #4
    well i'm italy so no genius bar here and tomorrow is saturday!! I'm so pissed of. I need my computer. Now i have to use by gf's 4 year old asus :( in XP land :mad: ! I hope nothing is wrong with the macbook itself. I mean it works perfectly just reports that it isn't charging and the light on the connector doesn't come on...

    oh well like a wise man said "s*** happens"


    :D

    Thanks for the help.
     
  5. Hipnomac macrumors regular

    Hipnomac

    Joined:
    Jun 14, 2007
    Location:
    Chicago
    #5
    Your computer is probably fine, mine was. When I got the new magsafe it worked fine. I guess sometimes they just die.
     

Share This Page