MagSafe Dims and MBP Sleeps - HELP!

Discussion in 'Mac Basics and Help' started by andrewdale, Jan 26, 2009.

  1. andrewdale macrumors 6502a

    Joined:
    Jan 28, 2008
    Location:
    Memphis, TN
    #1
    Hey everyone,

    I hope this isn't too repetitive, but I did some searching and couldn't find answers, so I'm asking here, hoping that someone can lead me in the right direction.

    Computer: 2.5GHz MBP, 4GB RAM, early 2008

    My MagSafe works fine, and then, it appears while I'm using it AS a laptop, the MagSafe light dims (still correct color, just VERY dim). This doesn't affect whether or not it is charging or not. However, if it gets unplugged while in this state, the computer just goes to sleep. It then has to be replugged, shut, and opened, and it goes back to normal.

    The other strange part, is if I barely unplug it then plug it back it, then the light goes back to normal until a few minutes later, when it dims again.

    All my software updates are up to date and such. And, since there's no "error" messages of the sort, no log files for me to check.

    So, a rundown of the problem.

    1. Dim MagSafe light
    2. Unplug and Computer goes to Sleep
    3. Replug, shut, reopen - back to normal

    I hope someone can help me with this, as I really don't want to have to go through the pain of setting up a Genius appointment.

    Thanks,
    Andrew
     
  2. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
  3. andrewdale thread starter macrumors 6502a

    Joined:
    Jan 28, 2008
    Location:
    Memphis, TN
    #3
    ::sigh::

    That's what I figured I'm going to have to do.

    Time to backup all my data just in case.
     
  4. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #4
    Have you tried all basics such as

    Reset SMU
    Reset PRAM
     
  5. andrewdale thread starter macrumors 6502a

    Joined:
    Jan 28, 2008
    Location:
    Memphis, TN

Share This Page