Magsafe doesnot charge the battery or pass the electricity

Discussion in 'MacBook Pro' started by kewlchak, Oct 4, 2008.

  1. kewlchak macrumors newbie

    Joined:
    Sep 18, 2008
    #1
    I recently bought my MacBook Pro 3 months back.Its performance is good.But a got a problem with the MAGSAFE power adapter.The ambient light does not come on when i try to charge the lappy nor do the battery gets charged.The battery completely drained off to 0%.I even tried to reset th SMC but no luck.
    The powerchord looks brand new with no defects at the pins an d AC end or the DC end.can anyone assist me what to do.:confused:


    thnxx
     
  2. mobilehaathi macrumors G3

    mobilehaathi

    Joined:
    Aug 19, 2008
    Location:
    The Anthropocene
    #2
    Take it to the Apple store or call support and have them replace it?
     
  3. Wotan31 macrumors 6502

    Joined:
    Jun 5, 2008
    #3
    If it's 3 months old, it's under warranty. Go to apple store and they'll replace it for you.
     
  4. kewlchak thread starter macrumors newbie

    Joined:
    Sep 18, 2008
    #4
    the problem is that i m in india now n i dont know whether the replacement can be done under the warrenty here. is it possible as such.
     
  5. mobilehaathi macrumors G3

    mobilehaathi

    Joined:
    Aug 19, 2008
    Location:
    The Anthropocene
    #5
    where did you buy it? Do you permanently live in India or are you just there for a little bit?
     
  6. kewlchak thread starter macrumors newbie

    Joined:
    Sep 18, 2008
    #6
    i bro got it for me from US.i permanently live in india
     
  7. ManWithhat macrumors regular

    Joined:
    Jun 24, 2008
    #7
    I had the same problem. Call applecare, they'll have you send it in and replace it. Not a huge fan of magsafe.
     
  8. mobilehaathi macrumors G3

    mobilehaathi

    Joined:
    Aug 19, 2008
    Location:
    The Anthropocene
    #8
    I think you might be out of luck. Maybe you could send the power cord to him and he could try to get it replaced?
     
  9. Davidkoh macrumors 65816

    Joined:
    Aug 2, 2008
    #9
    I had the same problem with my MacBook, I guess the pins in the magsafe has springs for the MBP too? I got frustrated (I was on vaccation in the states and it happened the first day), so I pushed in the pins in the magsafe a few times with some tool (do not have it plugged in while doing so), and that made it start working. Have worked good every since (a few months).
     
  10. kewlchak thread starter macrumors newbie

    Joined:
    Sep 18, 2008
    #10
    even dat doesnt help my problm
     
  11. iTunesFreak5454 macrumors newbie

    Joined:
    Oct 3, 2006
    #11
    I recently had this problem too. I had to buy a new power adapter.
     
  12. kewlchak thread starter macrumors newbie

    Joined:
    Sep 18, 2008
    #12
    got my magsafe replaced at d apple service centre for free.Love u Apple
     
  13. kewlchak thread starter macrumors newbie

    Joined:
    Sep 18, 2008
    #13
    replaced

    got my magsafe replaced at d apple service centre for free.Love u Apple
    thnqq all guys
     

Share This Page