magsafe led stopped working, whats next?

Discussion in 'MacBook Pro' started by squeeks, Apr 29, 2008.

  1. squeeks macrumors 68040

    squeeks

    Joined:
    Jun 19, 2007
    Location:
    Florida
    #1
    first
    see i did search

    ok my question

    so my LED works sometimes sometimes it doesnt, does this mean the next step is an exploding power adapter? or are the two problems most likly not linked? im guessing apple woulnt replace it either, since theres not really anyway to make it do this is just does it on its own ocasionally

    any ideas?
     
  2. forafireescape macrumors 6502a

    forafireescape

    Joined:
    Jan 16, 2008
    Location:
    NJ
    #2
    You should call AppleCare and see if they'll replace it. They might, since it has a defective light.
     
  3. philgilder macrumors 68000

    Joined:
    Sep 30, 2007
    Location:
    UK
  4. schradec macrumors newbie

    Joined:
    Apr 19, 2008
    Location:
    So California.
    #4
    Id call on it. Or if it is still very new (few weeks at the oldest) just go to the apple store, and I would bet they will swap one right then and there. Mine stopped working completely after a couple weeks and so I walked in and had a new one in 5 min. Love apples customer service.
     
  5. Skeletal-dæmon macrumors 6502

    Joined:
    Apr 27, 2008
    #5
    Is is a particular colour that doesn't work? Like its supposed to be orange when charging and green when charged... so maybe one of the coloured elements in the LED is burnt out if one of the colours still works as it should...
     
  6. squeeks thread starter macrumors 68040

    squeeks

    Joined:
    Jun 19, 2007
    Location:
    Florida
    #6
    well, i know green doesnt work, not sure about amber, its almost a year old(june 29th of 07), and it just started doing this a couple of weeks ago, ill call applecare sometime this week, how long are the hold times usually?
     
  7. bakerster macrumors regular

    Joined:
    Feb 14, 2008
    #7
    i just got a replacement magsafe and it does that too. i dont think its a problem.
     
  8. squeeks thread starter macrumors 68040

    squeeks

    Joined:
    Jun 19, 2007
    Location:
    Florida
    #8
    i found another thread on page 4

    this dosent look good
     
  9. orlando2483 macrumors newbie

    Joined:
    Mar 29, 2008
    #9
    I called apple care and had me send the computer in. After two days later the computer came back with the logic board replaced. After working with computer for about an hour, the stupid LED light on the charger died again. I called apple care and demanded full computer replacement (This was not the first problem on this computer, it was probably the eight problem). After all the hassles, apple sent me a brand new computer :D.

    At least this was my experience with that annoying LED light.
    And no, it is not within specs, like the Genius bar always responds to a simple question. :apple:
     
  10. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #10
    My MBP mid 2007 LED charger light sometimes doesn't show up when it's charging. Had it quite often a month ago, but haven't seen it much lately.
     
  11. jjahshik32 macrumors 603

    Joined:
    Sep 4, 2006
    #11
    I just think the led green light on the magsafe charger is just faulty. Because I noticed that even when the green light is not on it still charges the mbp fine and exactly how it should be charging. Apple just uses cheap green led on those little magsafe thats all.:D

    And just those 1 or 2 people that I saw that said their 2007 SR mbp had the same green led not come on sometimes is just coincidence that their battery happened to die.
     
  12. bluedoggiant macrumors 68030

    bluedoggiant

    Joined:
    Jul 13, 2007
    Location:
    MD & ATL,GA
    #12
    My father's 2.16ghz MacBook Pro is like that. He bought it in November 2007, it charges fine.
     
  13. watermelon macrumors regular

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #13
    this started happening to me a few weeks ago. A few days ago the power adapter just stopped working, and I had to get a new one.
     

Share This Page