magsafe led turning off

Discussion in 'Mac Basics and Help' started by maxmax, Jun 27, 2007.

  1. maxmax macrumors member

    Joined:
    Apr 16, 2007
    #1
    just want to see if anybody has had this happen --

    my macbook pro is fully charged (has been for two or three days) and plugged into the power adapter. i just noticed that the green led on the magsafe has turned off. the battery still reports "charged" and is running off the power. i'm just curious why the led on the magsafe turned off?

    i just unplugged it and plugged it right back in and the green led is back.

    any help?
     
  2. eyebeaz macrumors 6502

    Joined:
    Oct 22, 2006
    #2
    Same thing happens to my Macbook.. when the batter is fully charged the light sometimes turns off (at random?) yet it remains on battery power and fully charged. And like you if I unplug it and plug it back it turns back on. Weird.
     
  3. extraextra macrumors 68000

    extraextra

    Joined:
    Jun 29, 2006
    Location:
    California
    #3
    Mine does the same thing! Does anyone know why, and should I be concerned?

    The Macbook stays charged, and runs off the battery if I disconnect, but I have no idea why the little LED turns off on the MagSafe. It's only started happening.
     
  4. JasonMac macrumors regular

    JasonMac

    Joined:
    Jun 6, 2007
    #4
    Mine has never done this, weird!!! But as long as it still works I see no concern
     
  5. Ride9650 macrumors 6502

    Joined:
    Jun 29, 2007
    #5
    Though there is probably nothing wrong, it really can't hurt to have it checked out just to be safe, or at the very least calling apple and talking with a tech.
    Just my 2 cents
     
  6. maxmax thread starter macrumors member

    Joined:
    Apr 16, 2007
    #6
    i called apple back when i posted this. the tech said it wasn't normal behavior and to take it to the store and they could run a quick test. the genius didn't seem to test anything. just plugged it into his macbook and said it works fine. uhh, how conclusive. anyways, the light hasn't been turning off lately. if it starts happening again maybe i can get my adaptor switched out (hopefully for one of the newer, more compact ones.)
     
  7. bwyan macrumors newbie

    Joined:
    Oct 2, 2006
    Location:
    Reykjavík, Iceland
    #7
    Same thing goes for me.

    I've had the exact same experience with my MacBook. At the time it first happened to me, I actually didn't realize that my battery was fully charged, but it's very likely that it was.

    It's been a while since I've last seen this happen, though.

    As you guys are saying, no actual harm seems to come from this, when it does happen. The green LED goes out, but the battery stays charged. When "re-plugging" the cord, the green LED turns back on.

    Even so, it still think this needs to be addressed, if this some day becomes part of a problem, somehow.

    UPDATE:
    I just noticed it happen again today, this time I'm absolutely sure that the battery was NOT fully charged.
     
  8. extraextra macrumors 68000

    extraextra

    Joined:
    Jun 29, 2006
    Location:
    California
    #8
    I dunno, I'll have to go to the Apple store and ask.

    It happens regardless of whether the battery is charged or not (for me). When I plug it in to charge, the LED stays orange for a minute or so, then turns off. When it's charged, I can only tell by checking battery icon on the screen because the green doesn't show up. However, if I pull out the MagSafe and snap it back in, the LED will be green, and then it fades away after a minute or so.

    I haven't seen any problems with charging or staying charged, and the computer seems to be fine, so I have no idea what could be wrong.
     
  9. inhumandecency macrumors newbie

    Joined:
    Aug 17, 2007
    #9
    Personally, I like this problem. The multiple bright lights shining from the computer often bother me, especially when I'm trying to sleep. I hope that someday we'll get the option to disable them.
     
  10. ITASOR macrumors 601

    ITASOR

    Joined:
    Mar 20, 2005
    Location:
    Oneida, NY
    #10
    Just a warning, I would get your power adapter replaced ASAP. Many of the people that have experienced the magsafe melting or sparking have first noticed funny things about the LED was doing.
     
  11. darkcurse macrumors 6502a

    darkcurse

    Joined:
    Nov 5, 2005
    Location:
    Sydney
    #11
    Yeah it happens randomly for me too. At first I thought it was a "feature" since the first time it happened, I was just about to go to sleep. And I left it plugged to the mains for charging overnight. Was nice to not have to see that red LED haha
     
  12. miniConvert macrumors 68040

    miniConvert

    Joined:
    Mar 4, 2006
    Location:
    Kent, UK - the 'Garden of England'.
    #12
    Mine does it on my SR MBP charger. Doesn't bother me, but I'm keeping an eye on it anyway.
     

Share This Page