MagSafe light randomly stops working

Discussion in 'MacBook' started by celticpride678, Jan 22, 2010.

  1. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #1
    Over the past few months, I have noticed that my MagSafe light will randomly stop working when I plug it into my MacBook. I just unplug it, and plug it back in and it works normally. It seems like the computer still charges though. Any ideas? Thanks.
     
  2. bimmerfreak0 macrumors member

    Joined:
    Nov 9, 2008
    #2
    mine does this too...wondering if I should take it in...
     
  3. gibbz macrumors 68030

    Joined:
    May 31, 2007
  4. nullx86 macrumors 6502a

    nullx86

    Joined:
    Jun 26, 2009
    Location:
    Wilmington/Jacksonville, NC
    #4
    I dont have anything that requires a MagSafe, but if its just the LED on it, I highly doubt Apple will do anything about it. Now if its shorted out, or has any kind of brown markings from a burn or something along that line, then they are required to take care of it. But, you know the saying, "If it ain't broke....."
     
  5. celticpride678 thread starter Guest

    celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #5
    It has a slight brown outline on the brick...
     
  6. nullx86 macrumors 6502a

    nullx86

    Joined:
    Jun 26, 2009
    Location:
    Wilmington/Jacksonville, NC
    #6
    if its brown from being dirty, then its not related. Take it in if you think its due to a short or whatnot.
     

Share This Page