Magsafe only charges when upside down?

Discussion in 'MacBook Pro' started by orvn, Mar 12, 2011.

  1. orvn macrumors 6502

    Joined:
    Jan 11, 2011
    Location:
    Toronto, Canada
    #1
    I have a early 2010 unibody MBP 13. When I purchased it I received one of the older white-tipped Magsafe adapters, however, that one melted and I now have a silver-tipped one.

    Interestingly, the machine only charges when the Magsafe inlet is upside down (wire is facing toward me, alongside the USB/Firewire/SD ports).

    When I move it right side up (wire facing away), it doesn't charge (not even "not charging" mode).

    Is my Magsafe port just dirty or something? Can I fix this without going to the Apple Store? (I have a background in computer science and a history of both breaking and fixing expensive computing devices..)

    I am [2 months] out of warranty and I didn't buy Apple Care.
     
  2. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #2
    Mine does that sometimes but my son had the end in his mouth at some point and almost fried it so I always thought that was what was going on.
     
  3. devilcm3 macrumors 6502a

    Joined:
    Jan 3, 2011
    Location:
    South Melbourne, Australia
    #3
    tried other magsafe? perhaps from your friend's?

    you can always get an applecare even after your warranty ends , just that the warranty left would be only 46 months instead of full 48 months
     
  4. Kyzelios macrumors 6502

    Joined:
    Mar 6, 2011
    Location:
    Canada
    #4
    As far as I am aware, you can only register an AppleCare service agreement within your initial 1 year AppleCare service period that came with your Mac at time of purchase. You usually can't activate the extended service agreement after the initial year.
     
  5. skier777 macrumors 6502

    Joined:
    Jul 3, 2010
    #5
    The magsafe on my computer often takes a fair bit of convincing to work in some positions. Im pretty sure its just dirty, try cleaning both sides with alcohol on a qtip.

    The only other thing i can think of is that one of the wires broke in the cable, maybe where the wire enters the block. Since it can be used either way there may be a symmetrical set of wires running from the block, although i would have thought it would be easier to have done all that in the tip.
     
  6. orvn thread starter macrumors 6502

    Joined:
    Jan 11, 2011
    Location:
    Toronto, Canada
    #6
    I'll try the Q-tip tonight.

    Incidentally, my brother is visiting me from college tomorrow and I'll be able to give his adapter a go also.

    I'll post my results.
     
  7. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #7
    Read the section on CHARGING in the link below, especially the last part on troubleshooting the MagSafe and resetting the SMC. This should answer most, if not all, of your battery questions:
     

Share This Page