Magsafe power adapter has broken... twice

Discussion in 'MacBook' started by Drodrey, Feb 23, 2011.

  1. Drodrey macrumors newbie

    Joined:
    Jan 9, 2010
    #1
    I have a 2 year old aluminium macbook. In October last year I accidentally broke my charger, so I went to the mac store and bought the new "l-shape" adapter. In January it died. It spluttered for a couple of days... working sporadically with the light only working when I jiggled it, and then it died for sure. Took it to the mac store and had it replaced under warrenty, no problem.

    I'm having the same issue again, less than a month later. It's "spluttering" at the moment. It will work the majority of the time, but occassionally I'll look down and the light on the charger won't be on and my computer's at about 80%. Give it a jiggle, and it works again.

    Why have I killed two chargers in two months? Is it my macbook doing it, or have i just been unlucky enough to get two faulty ones.
     
  2. Shrink macrumors G3

    Shrink

    Joined:
    Feb 26, 2011
    Location:
    New England, USA
    #2
    Just an obvious suggestion, probably one you are already employing...when you remove the plug, grip the plug, don't pull the cable. I've had the same cable for 2 years with no damage of any kind. Also, if you roll it up, don't bend at the point of attachment between the cable and the plug.

    No offense intended if you are already doing these things. Actually no offense intended under any circumstances!!:p:)
     

Share This Page