Mail 2.0 - Text Encoding Preference

Discussion in 'Mac Apps and Mac App Store' started by Halcyon, May 19, 2007.

  1. Halcyon macrumors 6502

    Joined:
    Sep 21, 2006
    #1
    I've found out that when sending rich text mail from my Mac (using Mail 2.0 of course) those on the other end running PC's receive my mail full of "strange" characters that replace certain punctuation marks. This I can solve by changing the text encoding option from "Automatic" either to "Western (ISO Latin-1)" or "Wester (Windows Latin-1)".

    Being that "Automatic" text encoding is the default, to overcame the strange characters problem I must manually select one of the other options every time I send an e-mail. Is there a way to change the default text encoding to any of the other options?

    TIA
     
  2. Mitthrawnuruodo Moderator emeritus

    Mitthrawnuruodo

    Joined:
    Mar 10, 2004
    Location:
    Bergen, Norway
    #2
    Quit Mail, open Terminal and type (or just copy and paste) and hit enter:

    defaults write com.apple.mail NSPreferredMailCharset "ISO-8859-1"

    To get back to UTF-8 (which I think is the default), use:

    defaults write com.apple.mail NSPreferredMailCharset "UTF-8"
     
  3. Halcyon thread starter macrumors 6502

    Joined:
    Sep 21, 2006
    #3
    Thanks. I've done as you indicated and sent some mails out for verification (waiting on response).

    The Text Encoding Menu in Mail still has a tick mark next to Automatic, but I guess it will default to what is specified through Terminal command.

    There is no "ISO-8859-1" option in the Mail Text Encoding Menu, but I assume you recommend this because is the correct phrasing for either "Western (ISO Latin-1)" or "Wester (Windows Latin-1)"?

    TIA
     

Share This Page